机试之字符串匹配计数——POJ3461Oulipo
1、题目
题目链接:http://poj.org/problem?id=3461
题目大意为在文本text中找到单词W出现的次数,从而想到可以用KMP模式匹配的代码模板,再设置一个计数器cnt用来记录匹配成功的次数并返回输出即可
Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 60610 Accepted: 23441
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
Source:
BAPC 2006 Qualification
2、代码
//机试之字符串匹配计数——POJ3461Oulipo
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
const int MAXM = 10010;
int nextTable[MAXM];
void GetNextTable(string pattern){//构造next数组
int m = pattern.size();//获取模式串大小
int j = 0;
nextTable[j] = -1;
int t = nextTable[j];
while(j < m){
if(t == -1 || pattern[t] == pattern[j]){
++t;
++j;
nextTable[j] = t;
}
else{
t = nextTable[t];
}
}
}
int KMP(string text,string pattern){//文本串和模式串,返回第一次匹配成功的次数
GetNextTable(pattern);//构造next数组
int n = text.size();
int m = pattern.size();
int i = 0, j = 0,cnt = 0;
while(i < n){
if(j == -1 || text[i] == pattern[j]){
++i;
++j;
}
else{
j = nextTable[j];
}
if(j == m){
cnt++;
j = nextTable[j]; //允许字符重复的匹配
// j = 0; //不允许字符重复的匹配
}
}
return cnt;
}
int main(){
int T;
// cin>>T;
scanf("%d",&T);
while(T--){//样例数
string text,pattern;
cin>>pattern>>text;
printf("%d\n",KMP(text,pattern));
}
return 0;
}