【POJ3321】Apple Tree

18 篇文章 0 订阅
10 篇文章 0 订阅
Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 26622 Accepted: 7900

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

树状数组+DFS
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
#define LL long long
using namespace std;
const int N = 1e5+10;
int Left[N],Right[N],C[N];
typedef vector<int >IN;
vector<IN>graph(N);
bool vis[N];
int n,key;
int lowbit(int x) {
	return x&(-x);
}
void add(int x,int y) {
	while(x<=n) {
		C[x]+=y;
		x+=lowbit(x);
	}
}
int Sum(int x) {
	int s=0;
	while(x>0) {
		s+=C[x];
		x-=lowbit(x);
	}
	return s;
}
void dfs(int x) {
	Left[x]=key;
	for(int i=0; i<graph[x].size(); i++) {
		key++;
		dfs(graph[x][i]);
	}
	Right[x]=key;
}
void init() {
	for(int i=0; i<=n; i++) {
		Left[i]=0;
		Right[i]=0;
		C[i]=0;
		graph[i].clear();
	}
}
int main() {
	while(scanf("%d",&n)!=EOF) {
		init();
		for(int i=0; i<n-1; i++) {
			int a,b;
			scanf("%d%d",&a,&b);
			graph[a].push_back(b);
		}
		key=1,dfs(1);
		for(int i=1; i<=n; i++){
			vis[i]=1;
			add(i,1);
		}
		int m,x;
		char c;
		scanf("%d",&m);
		while(m--) {
			getchar();
			scanf("%c %d",&c,&x);
			if(c=='Q') {
				printf("%d\n",Sum(Right[x])-Sum(Left[x]-1));
			} else {
				int t=vis[x]==1?-1:1;
				add(Left[x],t);
				vis[x]=!vis[x];
			}
		}
	}
	return 0;
}
题目地址:http://poj.org/problem?id=3321

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值