【lightoj1331】Agent J【计算几何】

F - F 圆周率用acos(-1.0) 使用longlong
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Agent J is preparing to steal an antique diamond piece from a museum. As it is fully guarded and they are guarding it using high technologies, it's not easy to steal the piece. There are three circular laser scanners in the museum which are the main headache for Agent J. The scanners are centered in a certain position, and they keep rotating maintaining a certain radius. And they are placed such that their coverage areas touch each other as shown in the picture below:

Here R1R2 and R3 are the radii of the coverage areas of the three laser scanners. The diamond is placed in the place blue shaded region as in the picture. Now your task is to find the area of this region for Agent J, as he needs to know where he should land to steal the diamond.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing three real numbers denoting R1, R2 and R3 (0 < R1, R2, R3 ≤ 100). And no number contains more than two digits after the decimal point.

Output

For each case, print the case number and the area of the place where the diamond piece is located. Error less than10-6 will be ignored.

Sample Input

3

1.0 1.0 1.0

2 2 2

3 3 3

Sample Output

Case 1: 0.16125448

Case 2: 0.645017923

Case 3: 1.4512903270

只要注意细节别弄错精度上一般没问题,先用余弦定理求出每个圆对应的圆心角,然后就能求出该圆心角对应的扇形面积,用总面积减去各扇形面积就行了。
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#define PI acos(-1.0)
using namespace std;
double find(double a,double b,double c){
	return acos((b*b+a*a-c*c)/(2*a*b));
}
double cocu(double x,double r){
	return x*r*r/2;
}
int main() {
	int T,p=0;
	scanf("%d",&T);
	while(T--) {
		double r1,r2,r3;
		scanf("%lf%lf%lf",&r1,&r2,&r3);
		double w1,w2,w3;
		w1=find(r1+r2,r1+r3,r2+r3);
		w2=find(r1+r2,r2+r3,r1+r3);
		w3=find(r3+r1,r3+r2,r1+r2);
	//	printf("%lf %lf %lf--\n",w1,w2,w3);
		double s1,s2,s3,s;
		s1=cocu(w1,r1);
		s2=cocu(w2,r2);
		s3=cocu(w3,r3);
	//	printf("%lf %lf %lf==\n",s1,s2,s3);
		s=(r1+r2)*(r2+r3)*sin(w2)/2.0;
		printf("Case %d: %lf\n",++p,s-s1-s2-s3);
	}
	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值