LightOJ - 1331 Agent J (数学几何)求3圆之间的面积

LightOJ - 1331
Time Limit:                                                        1000MS                       Memory Limit: 32768KB64bit IO Format:                            %lld & %llu                       

SubmitStatus

Description

Agent J is preparing to steal an antique diamond piece from a museum. As it is fully guarded and they are guarding it using high technologies, it's not easy to steal the piece. There are three circular laser scanners in the museum which are the main headache for Agent J. The scanners are centered in a certain position, and they keep rotating maintaining a certain radius. And they are placed such that their coverage areas touch each other as shown in the picture below:

Here R1, R2 and R3 are the radii of the coverage areas of the three laser scanners. The diamond is placed in the place blue shaded region as in the picture. Now your task is to find the area of this region for Agent J, as he needs to know where he should land to steal the diamond.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing three real numbers denoting R1, R2 and R3 (0 < R1, R2, R3 ≤ 100). And no number contains more than two digits after the decimal point.

Output

For each case, print the case number and the area of the place where the diamond piece is located. Error less than 10-6 will be ignored.

Sample Input

3

1.0 1.0 1.0

2 2 2

3 3 3

Sample Output

Case 1: 0.16125448

Case 2: 0.645017923

Case 3: 1.4512903270

Hint

Source

Problem Setter: Jane Alam Jan
//题意:
给你三个圆的半径,这三个圆是两两相切的,让你求出这三个圆之间所夹的面积。
//思路:
先分析怎样得到那个阴影面积,将三个圆心连接后,形成一个三角形,扇形面积就等于三角形面积减去三个扇形面积。
怎样求三个扇形的面积呢?先用余弦定理求出每个角的cos值(因为三条边的长度已知),再根据cos值求出三个角的大小,再根据求扇形面积公式求出3个扇形面积,再用三角形面积减去3个扇形面积即可。
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#define PI acos(-1.0)
using namespace std;
int main()
{
	int t,T=1;
	double r1,r2,r3;
	scanf("%d",&t);
	while(t--)
	{
		double tmp,a,b,c,A,B,C,SA,CA,CB,CC;
		double S,s1,s2,s3,s;
		scanf("%lf%lf%lf",&r1,&r2,&r3);
		a=r1+r2;b=r1+r3;c=r2+r3;
		CA=(b*b+c*c-a*a)/(2*b*c);
		CB=(a*a+c*c-b*b)/(2*a*c);
		CC=(a*a+b*b-c*c)/(2*a*b);
		A=acos(CA);
		B=acos(CB);
		C=acos(CC);
		S=0.5*sin(B)*a*c;
		s1=0.5*A*r3*r3;
		s2=0.5*B*r2*r2;
		s3=0.5*C*r1*r1;
		s=S-s1-s2-s3;
		printf("Case %d: %.10lf\n",T++,s);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值