2021-05-04

10-排序6 Sort with Swap(0, i) (25 分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

 

#include<stdio.h>
#include<stdlib.h>
int GetNumber(int* a, int N);
int main()
{
	int N;
	scanf("%d", &N);
	int* a = (int*)malloc(sizeof(int) * N);
		for (int i = 0; i < N; i++)
		{
			scanf("%d", a + i);
		}
		printf("%d", GetNumber(a, N));
}
int GetNumber(int* a,int N )
{
	int* table = (int*)malloc(sizeof(int) * N);
	int cnt = 0;
	int Flag0;
	int CircleNumber=0;
	int i;//找环的起始位置
	int Number;
	int j;
	int T=0;
	for (int i = 0; i < N; i++)
	{
		if (a[i] != i)
			table[i] = 0;
		else
		{
			table[i] = 1;
			cnt++;
		}
	}
	Number = N - cnt;
	if (table[0] == 1)
		Flag0 = 0;
	else
		Flag0 = -2;
	while (cnt != N)
	{
		for (i = T; i < N; i++)
		{
			if (table[i] == 0)
			{
				T = i + 1;
				break;
			}
		}
		j = i;
		CircleNumber++;
		while (table[j] != 1)
		{
			table[j] = 1;
			cnt++;
			j = a[j];
		}
	}
	Number = Number + CircleNumber + Flag0;
	return Number;

}

就是找环数(一开始自己和自己成环的不算)以及判断0一开始在哪里(一开始超时了,增加T以后就好了)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值