2021-05-04

该博客内容涉及计算微博中用户帖子的最大潜在转发次数。给定一个用户网络,每个用户可以关注多个其他用户,形成一个社交网络。问题要求计算特定用户在只考虑L级间接关注者的情况下能触发的最大转发数。输入包括用户数量、关注层级以及查询的用户ID,输出为每个查询用户的最大转发数。示例展示了如何使用图数据结构和广度优先搜索算法来解决这个问题。
摘要由CSDN通过智能技术生成

1076 Forwards on Weibo (30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

 

#include<stdio.h>
#include<stdlib.h>
#include<queue>
#include<stdbool.h>
using namespace std;
typedef int Vertex;
typedef int WeightType;
typedef int DataType;

struct GNode {
	int Nv;
	int Ne;
	int** G;
};
typedef struct GNode* MyGraph;
MyGraph CreateGraph(int N);
void InitializeGraph(MyGraph Graph);
int GetForwardNumber(MyGraph Graph, Vertex A, int L);
int main()
{
	int N;
	scanf("%d", &N);
	int L;
	scanf("%d", &L);
	int Number;
	
	MyGraph Graph = CreateGraph(N);
	InitializeGraph(Graph);
	scanf("%d", &Number);
	int Vertex;
	for (int i = 0; i < Number; i++)
	{
		scanf("%d", &Vertex);
		printf("%d\n", GetForwardNumber(Graph, Vertex, L));
	}

}
MyGraph CreateGraph(int N)
{
	MyGraph Graph = (MyGraph)malloc(sizeof(struct GNode));
	Graph->Nv = N;
	Graph->G = (int**)malloc(sizeof(int*) * (N + 1));
	for (int i = 1; i <= N; i++)
	{
		Graph->G[i] = (int*)malloc(sizeof(int) * (N + 1));
	}
	return Graph;
}
void InitializeGraph(MyGraph Graph)
{
	int AdjNum;
	Vertex NodeName;
	for (int i = 1; i <= Graph->Nv; i++)
	{
		scanf("%d", &AdjNum);
		for (int j = 1; j <= AdjNum; j++)
		{
			scanf("%d", &NodeName);
			Graph->G[i][NodeName] = 1;//i,j为1表示i关注j(j被i关注)
			
		}
	}
}
int GetForwardNumber(MyGraph Graph, Vertex A,int L)
{
	int* QLevel = (int*)malloc(sizeof(int) * (Graph->Nv + 1));
	int* Trigger = (int*)malloc(sizeof(int) * (Graph->Nv + 1));
	int Item;
	int ForwardNumber = 0;
	queue <int>q;
	for (int i = 1; i <= Graph->Nv; i++)
	{
		Trigger[i] = true;
		QLevel[i] = 0;
	}
	Trigger[A] = false;
	q.push(A);
	while (q.size())
	{
		Item = q.front();
		if (QLevel[Item] < L)
		{
			q.pop();
			for (int i = 1; i <= Graph->Nv; i++)
			{
				if (Graph->G[i][Item]&&Trigger[i] == true)
				{
					q.push(i);
					Trigger[i] = false;
					QLevel[i] = QLevel[Item] + 1;
					ForwardNumber++;
				}

			}
		}
		else
		{
			q.pop();
		}


	}
	return ForwardNumber;

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值