使用multimap和multiset

基础实验5-2.2 电话聊天狂人 (25 分)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(≤10​5​​),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3
#include<stdio.h>
#include<stdlib.h>
#include<stdbool.h>
#include<math.h>
#include<map>
#include<iostream>
#include<string>
#include<set>
using namespace std;
struct Tel {
    int times;
    string TelNum;
};
struct Rule {
    bool operator()(const Tel& a1, const Tel& a2)const
    {
        if (a1.times != a2.times)
            return a1.times > a2.times;
        else
            return a1.TelNum < a2.TelNum;
    }
};
int main()
{
    string TelNum1, TelNum2;
    map<string, int>mp;
    map<string, int>::iterator p;
    multiset<Tel, Rule>st;
    multiset<Tel, Rule>::iterator q;
    Tel t;
    int N;
    int num=0;
    scanf("%d", &N);
    for (int i = 0; i < N; i++)
    {
        cin >> TelNum1 >> TelNum2;
        ++mp[TelNum1];
        ++mp[TelNum2];
    }
    for (p = mp.begin(); p != mp.end(); p++)
    {
        t.TelNum = p->first;
        t.times = p->second;
        st.insert(t);
    }
    for (q = st.begin(); q != st.end(); q++)
    {
        if (q->times == st.begin()->times)
        {
            num++;
        }
    }
    if (num == 1)
        cout << st.begin()->TelNum << " " << st.begin()->times;
    else
        cout << st.begin()->TelNum << " " << st.begin()->times<<" "<<num;

}
                             

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值