bfx849079281的博客

计算机硬件简单介绍

中小型企业网络构建之DHCP

中小型企业网络构建

一、DHCP基础

  1、DHCP的使用背景

      -- 在现在的企业网络中,有大量的主机或设备需要获取IP地址等网络参数;

         @ 如果采用手工配置,工作量大,容易出错且不好管理

         @ 如果有用户擅自更改,还有可能会造成IP地址冲突等问题

      -- 使用动态主机配置DHCP协议来分配IP地址等网络参数,可以减少管理员的工作量,避免出错。

  2、DHCP的定义

            DHCP(Dynamic Host Configuration Protocol)动态主机配置协议,是一个局域网的网络协议,使用UDP协议工作;

主要有两个用途:给内部网络或网络服务供应商自动分配IP地址,给用户或者内部网络管理员作为对所有计算机作中央管理的手段;

DHCP有3个端口,其中UDP67和UDP68为正常的DHCP服务端口,分别作为DHCP Server和DHCP Client的服务端口;546号端口用于DHCPv6 Client,而不用于DHCPv4,是为DHCP failover服务,这是需要特别开启的服务,DHCP failover是用来做"双机热备"的。

  3、DHCP的作用

      -- 用于实现企业用户IP地址的动态分配和集中管理

      -- 避免繁琐的手工配置,快速适应网络的变化

  4、DHCP的角色

      -- DHCP客户端(DHCP Client)

         DHCP客户端就是希望通过DHCP服务器DHCP Server获取IP地址信息分配的用户主机或者其他设备,例如PC、手机、IP电话等。

      -- DHCP服务器(DHCP Server)

         DHCP服务器负责处理来自DHCP客户端或DHCP客户端或DHCP中继的地址分配、地址续租、地址释放等请求,为客户端分配IP地址和其他网络配置信息。

      -- DHCP中继(DHCP Relay)

         如果DHCP服务器和DHCP客户端在同一个网段范围内则不需要DHCP中继,如果DHCP服务器和DHCP

客户端不在同一个网段,则需要由DHCP中继负责DHCP服务器与DHCP客户端之间的DHCP报文转发。这样

可以避免在每个网段范围内都部署DHCP服务器,既节省了成本,又便于集中管理。

  5、DHCP报文

      DHCP服务一样工作在C/S(客户端/服务器)模式,但两者进行报文传输时所用的UDP传输端口是不一样

的,DHCP客户端使用68号UDP端口发送请求报文;DHCP服务器使用67号UDP端口发送应答报文。DHCP客户

端向DHCP服务器发送的报文称为DHCP请求报文,而DHCP服务器向DHCP客户端发送的报文称为DHCP应答报

文。

  6、DHCP报文类型

      -- DHCP Discover 发现报文(请求IP地址时不知道DHCP服务器的位置,所以在本地网络内广播形

式发送该报文,用来发现网络中的DHCP服务器,所有收到报文的服务器均会回应)

-- DHCP Offer    提供报文(每一台DHCP收到Discover报文的服务器,都会在所配置的地址池中查找

一个合适的IP地址,加上相应的租约期限和其他配置信息,构造一个Offer报文,以广播的形式发送给客户端,告知客户端,本服务器可以为其提供IP地址)

      -- DHCP Request 请求报文DHCP客户端会收到很多Offer报文,所以必须在这些应答中选一个并且

以广播的形式向该服务器发送DHCP Request报文)

      -- DHCP ACK 确认报文DHCP服务器收到Request请求报文后,根据Request报文中的携带的用户

MAC来查找有没有相应的租约记录,如果有则发送ACK应答报文)

      -- DHCP NAK 拒绝报文(如果DHCP服务器收到Request请求报文后,没有发现有没有相应的租约记

录,或者由于某些原因无法正常分配IP地址,则向DHCP客户端发送NAK应答报文)

      -- DHCP Release 释放IP地址(如果DHCP客户端不在需要使用分配的IP地址时,就会主动向DHCP服务

器发送Release请求报文,告知服务器用户不在需要分配IP地址,请求DHCP服务器释

放对应的IP地址)

      -- DHCP Decline 拒绝报文(DHCP客户端收到DHCP服务器ACK应答报文后,通过地址冲突检测发现服务器分配的地址冲突或者由于其他原因导致不能使用,则会想DHCP服务器发送Decline请求报文,通知服务器所分配的IP地址不可用,以期获得新的IP地址)

      -- DHCP Inform  请求配置参数报文(DHCP客户端如果需要从DHCP服务器端获取更为详细的配置信息,则向DHCP服务器发送Inform请求报文;DHCP服务器在收到该报文后,将根据租约查找到相应的配置信息后,向DHCP客户端发送ACK应答报文。)

  5、DHCP的工作原理

      -- 客户机寻找服务器;

-- 服务器响应请求;

-- 客户机发送请求;

-- 服务器确认租约。

  6、DHCP配置基础

    1)DHCP服务规划

          -- 服务器规划(合理规划VLAN,确保同一个VLAN内仅有一台DHCP Server,能收到此VLAN内客户

端的请求;)

          -- IP地址规划

             -- DHCP Server可供自动分配的IP地址的范围

             -- 不参与分配的IP地址

          -- 租期规划

             -- 合理规划租期,缺省情况下,IP地址租期为1天

     2)开启DHCP功能

          配置DHCP服务器功能之前,必须先在系统视图下开启DHCP功能

          <Huawei>system-view

          [Huawei]dhcp enable

二、DHCP的集中配置模式

1、基于全局的DHCP

第一步:在路由器上建立地址池,并命名,配置网段、网关、DNS和租约

<Huawei>system-view                                     进入系统视图                                 

[Huawei]sysname + 路由名字(可以设置任何名字,如DHCP  路由器命名

[DHCP]ip pool + 地址池名字(可以设置任何名字,如P1)    新建地址池

[DHCP-ip-pool-P1]network 192.168.1.0 mask 255.255.255.0  设置一个网段

[DHCP-ip-pool-P1]gateway-list 192.168.1.254              设置网关地址(自定义)

[DHCP-ip-pool-P1]DNS list 8.8.8.8                        设置DNS地址   

[DHCP-ip-pool-P1]lease day + 天数                        设置DHCP租约时间

第二步:开启路由器DHCP功能

[DHCP]dhcp enable                        系统视图下开启路由器DHCP功能

第三步:给路由器接口配置地址,并在接口上启用DHCP功能

[DHCP]interface GigabitEthernet 0/0/0    进入接口视图

[DHCP-GigabitEthernet0/0/0]ip address 192.168.1.254 24接口配置IP地址

注意:接口地址要和网关地址一致

[DHCP-GigabitEthernet0/0/0]dhcp select global 接口下启用基于全局的DHCP

2、基于接口的DHCP

第一步:开启路由器DHCP功能

        <Huawei>system-view                   进入系统视图                                   

        [Huawei]sysname + 名字,如DHCP       给路由命名

第二步:给路由器接口配置地址,并在接口上启用DHCP功能

[DHCP]interface GigabitEthernet 0/0/0 进入接口视图

[DHCP-GigabitEthernet0/0/0]ip address 192.168.1.254 24   给接口配置IP地址和子网掩码

注意:网关地址就是接口地址

[DHCP-GigabitEthernet0/0/0]dhcp select interface         在接口下应用基于接口DHCP功能

[DHCP-GigabitEthernet0/0/0]dhcp sever dns-list 8.8.8.8             设置DNS地址

注意:真实环境下用运营商提供的地址

[DHCP-GigabitEthernet0/0/0]dhcp sever lease day + 天数             设置DHCP租约时间

[DHCP-GigabitEthernet0/0/0]dhcp sever excluded-ip address + 地址   设置保留地址

三、DHCP中继及其配置

1、DHCP中继(dhcp relay)当你的 DHCP 客户端与 DHCP 服务器不在同一个网段的时候,就要用DHCP

中继。DHCP中继通常配置在DHCP 客户端所在的 VLAN 的 “网关接口”上。

    2、配置命令

# dhcp enable

# interface vlanif 10 ----> dhcp select relay

                                 dhcp relay server-ip  192.168.88.88

3、导致的结果:

      将收到的以广播方式发送的 DHCP 报文,转换成“以单播方式”发送的 报文,

  然后转发给了指定的 DHCP 服务器; 

实验一:DHCP 中继

需求:

    PC-1/2/3/4通过 DHCP 获得对应网段的IP地址;

PC-1/2/3/4能够实现互相 ping 通 ; 

配置思路:

  1、配置 DHCP 客户端

         -双击模拟器,选择“DHCP”,然后应用。

   2、配置 DHCP 客户端与 DHCP 服务器中间的传输网络

         -创建 VLAN

    -配置端口模式:access + trunk  

    -配置 SW1 为 vlan 10 / 200

    -配置 SW1 与 DHCP-Server 之间的连通性

   SW1/2:

    [huawei]vlan batch 10 200 300

交换机1

[SW1]interface gi0/0/1

            [SW1-gi0/0/1] port link-type access

            [SW1-gi0/0/1] port default vlan 10

  [SW1]interface gi0/0/2

            [SW1-gi0/0/2] port link-type access

            [SW1-gi0/0/2] port default vlan 200

  [SW1]interface gi0/0/24

[SW1-gi0/0/24] port link-type trunk

[SW1-gi0/0/24] port trunk allow-pass vlan all 

交换机2

  [SW2]interface gi0/0/3

            [SW2-gi0/0/3] port link-type access

            [SW2-gi0/0/3] port default vlan 10

  [SW2]interface gi0/0/4

            [SW2-gi0/0/4] port link-type access

            [SW2-gi0/0/4] port default vlan 200

   [SW2]interface gi0/0/1

            [SW2-gi0/0/24] port link-type trunk

            [SW2-gi0/0/24] port trunk allow-pass vlan all  

          交换机1

[SW1]interface vlan 10

[SW1-vlan10] ip address 192.168.10.254 255.255.255.0

            [SW1]interface vlan 200

  [SW1-vlan200] ip address 192.168.200.254 255.255.255.0

  [SW1]interface gi0/0/3

            [SW1-gi0/0/3] port link-type access

            [SW1-gi0/0/3] port default vlan 300

            [SW1]interface vlan 300

  [SW1-vlan300] ip address 192.168.88.66 255.255.255.0           

   3、配置 DHCP 服务器 

         -为 DHCP-Server 配置IP地址;

         -配置 DHCP 地址池 (vlan-10 /  vlan-200)

         -配置接收 DHCP 报文的接口的 dhcp 地址池选择方式

         -开启 DHCP 功能

         -配置一个默认路由指向 SW1

        [DHCP-Server] interface gi0/0/0

        [DHCP-Server-gi0/0/0] ip address 192.168.88.88 255.255.255.0

          [DHCP-Server] ip pool VLAN-10

[DHCP-Server-pool-vlan-10] network 192.168.10.0 mask 255.255.255.0

       [DHCP-Server-pool-vlan-10] gateway-list 192.168.10.254

       [DHCP-Server-pool-vlan-10] dns-list 8.8.8.8

              [DHCP-Server] ip pool VLAN-200

[DHCP-Server-pool-vlan-200] network 192.168.200.0 mask 255.255.255.0

[DHCP-Server-pool-vlan-200] gateway-list 192.168.200.254

[DHCP-Server-pool-vlan-200] dns-list 8.8.8.8

          [DHCP-Server] dhcp enable

       [DHCP-Server] interface gi0/0/0

[DHCP-Server-gi0/0/0]dhcp select global

     4、配置 vlan10 与 vlan200 的网关为 DHCP 中继;

       [SW1] dhcp enable

       [SW1]interface vlanif 10

       [SW1-vlanif10] dhcp select relay

       [SW1-vlanif10] dhcp relay server-ip 192.168.88.88

       [SW1]interface vlanif 200

       [SW1-vlanif200] dhcp select relay

       [SW1-vlanif200] dhcp relay server-ip 192.168.88.88

     5、配置 DHCP-Server 的返回路由

       [DHCP-Server] ip route-static 0.0.0.0 0.0.0.0 192.168.88.66

     6、验证与测试

       pc-1/2/3/4 : ipconfig

   PC-1:

      ping 192.168.10.3  |    ping 192.168.200.2/4

实验DHCP 中继

要求:DHCP Client成功获取到IP地址;

配置思路:

   1、配置DHCP客户端;

   2、配置 SW1 ,确保 DHCP客户端与网关之间的正确连通性;

   3、配置 DHCP 服务器;

   4、配置 网关为 DHCP 中继;

   5、验证与测试

配置步骤:

    1、配置 DHCP 客户端;

2、配置 SW1

[SW1]vlan 10

[SW1]interface gi0/0/1

[SW1-gi0/0/1] port link-type access

[SW1-gi0/0/1] port default vlan 10

[SW1]interface gi0/0/2

[SW1-gi0/0/2] port link-type access

[SW1-gi0/0/2] port default vlan 10

       配置网关:

[Gateway]interface gi0/0/0

          [Gateway-gi0/0/0] ip address 192.168.10.254 255.255.255.0

   [Gateway]interface gi0/0/1

[Gateway-gi0/0/1] ip address 192.168.12.1 255.255.255.0

    3、配置 DHCP服务器

[DHCP-Server] interface gi0/0/1

[DHCP-Server-gi0/0/1] ip address 192.168.12.2 255.255.255.0

[DHCP-Server] ip pool VLAN-10

          [DHCP-Server-pool-vlan-10] network 192.168.10.0 mask 255.255.255.0

          [DHCP-Server-pool-vlan-10] gateway-list 192.168.10.254

[DHCP-Server-pool-vlan-10] dns-list 8.8.8.8

[DHCP-Server] dhcp enable

[DHCP-Server] interface gi0/0/1

[DHCP-Server-gi0/0/1] dhcp select global

[DHCP-Server] ip route-static 0.0.0.0 0.0.0.0 192.168.12.1 

    4、配置 网关为 DHCP 中继

[Gateway] dhcp enable

   [Gateway] interface gi0/0/0

   [Gateway-gi0/0/0] dhcp select relay

   [Gateway-gi0/0/0] dhcp relay server-ip 192.168.12.2

 5、验证与测试

        DHCP-Client :

     ipconfig -> 可以看到相应的IP地址,就成功了。

 

   

阅读更多
想对作者说点什么? 我来说一句

构建中小企业网络V6.0学习课件

2010年06月23日 16.54MB 下载

构建中小企业网络.pdf

2010年04月11日 35KB 下载

中小型企业网络拓扑图

2009年12月10日 24KB 下载

GNS3模拟一个中小型企业网络

2013年07月19日 296KB 下载

中小型企业网络搭建配置命令

2011年07月03日 582KB 下载

中小型企业网络组建方案

2009年04月27日 18KB 下载

没有更多推荐了,返回首页

不良信息举报

中小型企业网络构建之DHCP

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭