辽宁2010 time

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

Input

There are several test cases.

Each case contains 4 integers in a line, separated by space.

Proceed to the end of file.

Output

For each test case, output the time expressed by the digital clock such as Sample Output.

Sample Input

1 2 5 6
2 3 4 2

Sample Output

    _  _  _ 
  | _||_ |_ 
  ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_ 

#include<iostream>
using namespace std;
int main()
{
        int a,b,c,d;
      char str1[10][5]= {" _ ","   "," _ "," _ ","   "," _ "," _ "," _ "," _ "," _ "};           
        char str2[10][5]= {"| |","  |"," _|"," _|","|_|","|_ ","|_ ","  |","|_|","|_|"};
        char str3[10][5]= {"|_|","  |","|_ "," _|","  |"," _|","|_|","  |","|_|"," _|"};


    while(cin>>a>>b>>c>>d)
        {
               cout<<str1[a]<<str1[b]<<str1[c]<<str1[d]<<endl;       
               cout<<str2[a]<<str2[b]<<str2[c]<<str2[d]<<endl;                  
               cout<<str3[a]<<str3[b]<<str3[c]<<str3[d]<<endl;                 
        }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值