继续畅通工程

Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。 
 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。 

当N为0时输入结束。
 

Output

每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

Sample Input

       
       
3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
 

Sample Output

       
       
3 1 0
 
#include <iostream>
#include <cstdio>
#include <algorithm>
#define N 5000
using namespace std;
int par[101];
struct road
{
    int s,e,v,t;
}r[N];
void Init(int n)
{
    for(int i=0;i<=n;i++)
        par[i]=i;
}
int findroot(int x)
{
    if(par[x]!=x)
        return par[x]=findroot(par[x]);
    return par[x];
}
int unite(int x,int y)
{
    x=findroot(x);
    y=findroot(y);
    if(x==y)
        return 0;
    else
        par[y]=x;
    return 1;
}
bool cmp(const struct road &a,const struct road &b)
{
    return a.v<b.v;
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n!=0)
    {
        Init(n);
        int ans=0;
        for(int i=0;i<n*(n-1)/2;i++)
        {
            scanf("%d%d%d%d",&r[i].s,&r[i].e,&r[i].v,&r[i].t);
            if(r[i].t==1)
                r[i].v=0;
        }
        sort(r,r+n*(n-1)/2,cmp);
        for(int i=0;i<n*(n-1)/2;i++)
        {
            if(findroot(r[i].s)!=findroot(r[i].e))
            {
                unite(r[i].s,r[i].e);
                ans+=r[i].v;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值