Goldbach’s Conjecture(哥德巴赫猜想)(素数筛)

For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.

给你一个n >=4, 至少一对 p1 p2, n = p1+p2
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds.

没被证伪

However, one can find such a pair of prime numbers, if any, for a given even number.

给你一个n,你可以找到那么一对prime

The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

程序目的:cout有多少对prime满足p1+p2 = n

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

Output
Each output line should contain an integer number. No other characters should appear in the output.

Sample Input
6
10
12
0

Sample Output
1
2
1

Source
Asia 1998, Tokyo (Japan)

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <map>
#include <stack>
using namespace std;


bool judge[50001];// 0-5W 是否素数
vector<int> prime;

void initial(int bound) {
    judge[0] = 0;
    judge[1] = 0;
    for(int i = 2; i <= bound ; i ++) {
        judge[i] = 1;
    }

    for (int i = 2 ; i <= bound; i ++) {
        if(judge[i]) {
            prime.push_back(i);
            //倍数不是
            for ( int j = 2 * i; j <= bound; j += i) {
                judge[j] = 0;
            }
        }
    }
}




int getResult(int n) {
    int cnt = 0;
    int maxIndex = prime.size() - 1 ;
    for(int i = 0; i <= maxIndex; i++) {
        if(prime[i] > n / 2) {
            return cnt;
        }
        int res = n - prime[i];
        if (res <= 0) {
            return cnt;
        }
        if (judge[res]) {
            cout << "prime:" << prime[i] << " + " << res << endl;
            cnt ++;
        }

    }

    return cnt;

}


int main() {
    initial(50000);
    int n;
    while(cin >> n && n != 0) {
        cout << getResult(n) << endl;

    }

}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值