畅通工程(并查集)

Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

 

 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3(城镇数目、道路数目)
1 2
1 2
2 1


这种输入也是合法的
当N为0时,输入结束,该用例不被处理。

 

 

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。

 

 

Sample Input

4 2

1 3

4 3

 3 3

1 2

1 3

2 3

5 2

1 2

3 5

999 0 

0

 

 

Sample Output

1

0

2

998

 

 

如果有1个连通分量,那说明都连接好了 需要建0个公路

如果有2个连通分量,需要1个公路

如果有3个连通分量,需要2个公路

如果有4个连通分量,需要3个公路

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <map>
#include <stack>
#include <iomanip>
using namespace std;

class UnionFind {
    int father[1001]; // 0 ~ 1000  记录上级/老大
    int contain[1001]; // 包含多少小弟
    int minIndex; // 范围
    int maxIndex; // 范围
    int cnt; //连通分量的个数

public :
    UnionFind() {}
    UnionFind(int minIndex, int maxIndex) {
        // 1 ~ 4
        this->minIndex = minIndex;
        this->maxIndex = maxIndex;
        this->cnt = maxIndex - minIndex + 1; // 连通分量的个数

        for (int i = minIndex; i <= maxIndex ; i++) {
            father[i] = -1;
            contain[i] = 1;
        }

    }

    int getRoot(int x) {
        if (father[x] == -1) {
            return x;  // 自己就是老大
        } else {
            //自己不是老大,自己有上级
            // 上级是set老大 还是 图上的父节点?
            int d = father[x];
            int root = getRoot(d);
            if (d != root) {
                father[x] = root; // 直接跟root算了,不跟图上的父节点
                contain[d] -= contain[x]; // contain少了,投奔root了
            }
            return root;
        }

    }

    bool isConnected(int x, int y) {
        return getRoot(x) == getRoot(y);
    }

    bool connect(int x, int y) {
        int xRoot = getRoot(x);
        int yRoot = getRoot(y);
        if (xRoot == yRoot) {
            //cout << "已经在同一个set里面了" << endl;
            return false; // 已经在同一个set里面了,已经在同一个连通分量里面了
        } else {
            if(contain[x] >= contain[y]) {
                // x 人多势大, y投奔x
                father[yRoot] = xRoot;
                contain[xRoot] += contain[yRoot];
            } else {
                // y人多势大,x投奔y
                father[xRoot] = yRoot;
                contain[yRoot] += contain[xRoot];
            }
        }
        cnt --; //连通分量少1
    }

    int getCnt() {
        return cnt;
    }


    void show() {
        cout << "---目前情况---" << endl;
        cout << "father :";
        for (int i = minIndex; i <= maxIndex; i++) {
            cout << setw(4) << father[i] << "\t";
        }
        cout << endl;

        cout << "index  :";
        for (int i = minIndex; i <= maxIndex; i++) {
            cout << setw(4)  << i << "\t";
        }
        cout << endl << endl;


        cout << "contain :";
        for (int i = minIndex; i <= maxIndex; i++) {
            cout << setw(4)  << contain[i] << "\t";
        }
        cout << endl;

        cout << "index  :";
        for (int i = minIndex; i <= maxIndex; i++) {
            cout << setw(4)  << i << "\t";
        }
        cout << endl;

        cout << "---打印完毕---" << endl << endl;
    }



};



int main() {

    int n, m; // n是城镇的数目 m是道路的数目
    int x, y; // 临时变量,用来存储两个城镇
    while(cin >> n  && n != 0) {
        cin >> m;
        UnionFind uf(1, n);
        for (int i = 1 ; i <= m; i++) {
            cin >> x >> y;
            uf.connect(x, y);
        }
        int res = uf.getCnt() - 1;
        cout <<  res << endl;

    }




}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值