连通图(输入所有边,判断图是否连通) (并查集)

题目描述:

    给定一个无向图和其中的所有边,判断这个图是否所有顶点都是连通的。

输入:

    每组数据的第一行是两个整数 n 和 m(0<=n<=1000)。n 表示图的顶点数目,m 表示图中边的数目。如果 n 为 0 表示输入结束。随后有 m 行数据,每行有两个值 x 和 y(0<x, y <=n),表示顶点 x 和 y 相连,顶点的编号从 1 开始计算。输入不保证这些边是否重复。

输出:

    对于每组输入数据,如果所有顶点都是连通的,输出"YES",否则输出"NO"。

样例输入:

4 3
1 2
2 3
3 2
3 2
1 2
2 3
0 0
样例输出:

NO

YES

 

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <map>
#include <stack>
#include <iomanip>
using namespace std;


class UnionFind {
    int father[1001]; // 0 ~ 1000  记录上级/老大
    int contain[1001]; // 包含多少小弟
    int minIndex; // 范围
    int maxIndex; // 范围
    int cnt; //连通分量的个数

public :
    UnionFind() {}
    UnionFind(int minIndex, int maxIndex) {
        // 1 ~ 4
        this->minIndex = minIndex;
        this->maxIndex = maxIndex;
        this->cnt = maxIndex - minIndex + 1; // 连通分量的个数

        for (int i = minIndex; i <= maxIndex ; i++) {
            father[i] = -1;
            contain[i] = 1;
        }

    }

    int getRoot(int x) {
        if (father[x] == -1) {
            return x;  // 自己就是老大
        } else {
            //自己不是老大,自己有上级
            // 上级是set老大 还是 图上的父节点?
            int d = father[x];
            int root = getRoot(d);
            if (d != root) {
                father[x] = root; // 直接跟root算了,不跟图上的父节点
                contain[d] -= contain[x]; // contain少了,投奔root了
            }
            return root;
        }

    }

    bool isConnected(int x, int y) {
        return getRoot(x) == getRoot(y);
    }

    bool connect(int x, int y) {
        int xRoot = getRoot(x);
        int yRoot = getRoot(y);
        if (xRoot == yRoot) {
            //cout << "已经在同一个set里面了" << endl;
            return false; // 已经在同一个set里面了,已经在同一个连通分量里面了
        } else {
            if(contain[x] >= contain[y]) {
                // x 人多势大, y投奔x
                father[yRoot] = xRoot;
                contain[xRoot] += contain[yRoot];
            } else {
                // y人多势大,x投奔y
                father[xRoot] = yRoot;
                contain[yRoot] += contain[xRoot];
            }
        }
        cnt --; //连通分量少1
    }

    int getCnt() {
        return cnt;
    }


    void show() {
        cout << "---目前情况---" << endl;
        cout << "father :";
        for (int i = minIndex; i <= maxIndex; i++) {
            cout << setw(4) << father[i] << "\t";
        }
        cout << endl;

        cout << "index  :";
        for (int i = minIndex; i <= maxIndex; i++) {
            cout << setw(4)  << i << "\t";
        }
        cout << endl << endl;


        cout << "contain :";
        for (int i = minIndex; i <= maxIndex; i++) {
            cout << setw(4)  << contain[i] << "\t";
        }
        cout << endl;

        cout << "index  :";
        for (int i = minIndex; i <= maxIndex; i++) {
            cout << setw(4)  << i << "\t";
        }
        cout << endl;

        cout << "---打印完毕---" << endl << endl;
    }



};


int main() {
    int n, m; // 顶点数 边数
    int x, y;
    while (cin >> n >> m && n != 0 && m != 0) {
        UnionFind uf(1,n);
        for (int i = 1; i <= m; i++) {
            cin >> x >> y;
            uf.connect(x, y);
        }
        if (uf.getCnt() == 1) {
            cout << "YES" << endl;
        } else {
            cout << "NO" << endl;
        }
    }

}



还是用类好,否则每个案例 要重新重置内容,数据暴露在外面,不爽

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值