HDU 1004 Let the Balloon Rise

Letthe Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    MemoryLimit: 65536/32768 K (Java/Others)
Total Submission(s): 44096    Accepted Submission(s): 15575


Problem Description

Contesttime again! How excited it is to see balloons floating around. But to tell youa secret, the judges' favorite time is guessing the most popular problem. Whenthe contest is over, they will count the balloons of each color and find theresult.

This year, they decide to leave this lovely job to you. 

 

 

Input

Inputcontains multiple test cases. Each test case starts with a number N (0 < N<= 1000) -- the total number of balloons distributed. The next N linescontain one color each. The color of a balloon is a string of up to 15lower-case letters.

A test case with N = 0 terminates the input and this test case is not to beprocessed.

 

 

Output

Foreach case, print the color of balloon for the most popular problem on a singleline. It is guaranteed that there is a unique solution for each test case.

 

 

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

 

 

Sample Output

red

pink

 

 

Author

WU,Jiazhi

 

 

Source

ZJCPC2004

 

 

Recommend

JGShining

 

题目大意:输出颜色出现最多次数的颜色;

解题思路:用stl map做

/*Let the Balloon Rise HDU1004*/
#include <iostream>
#include <cstdio>
#include <map>
using namespace std;

map<string, int> m;
int main(int argc, char *argv[])
{
    int n;
    string ball;
    while(scanf("%d",&n)!=EOF,n)
    {
        int max=0;
        for(int i=0; i<n; i++)
        {
            cin>>ball;
            m[ball]+=1;
            if(max<m[ball])
                max=m[ball];        
        }
        map<string, int>::iterator it=m.begin();
        for(;it!=m.end();it++)
        {
            if(max==it->second)
                cout<<it->first<<endl;
        }
        m.clear();            
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值