HDU 1711 Number Sequence(KMP入门)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6786    Accepted Submission(s): 3084


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

Source
 
  hdu kmp入门题,一开始看到这个题目,看了数据范围,就直接否定了自己最开始想到的算法O(m*n)。想着用stl string中的find,网上查了一下string中find时间复杂度是O(m*n)的,接下来就是补基础,看《算法导论》,一知半解的,根据书上的伪代码勉强AC了,跑了500ms,膜拜一下跑进100ms的牛牛,希望能得到各路大虾们的指点,俺也优化优化。
#include <stdio.h>
#define nMax 1000002
int a[nMax],b[nMax];//a为文本,b为模式串 
int s[nMax]; //前缀函数 
int n,m;
void compute(){//计算前缀函数 
	int k=0,q;
	s[1]=0;
	for(q=2;q<=m;q++){
		while(k>0 && b[k+1]!=b[q]){
			k=s[k];
		}
		if(b[k+1]==b[q])
			k=k+1;
		s[q]=k;		
	}
}

void kmpmatch(){
	int q=0,i,j;//q记录已经匹配到的模式串中的个数 
	for(i=1;i<=n;i++){//从左至右逐个匹配文本中的字符 
		while(q>0&&b[q+1]!=a[i]){
			q=s[q];				//下一个字符未能匹配,通过前缀函数计算下个文本匹配的位置			
		}
		if(b[q+1]==a[i])//下一个字符能匹配 
			q=q+1;
		if(q==m){//模式串中字符全部匹配 
			printf("%d\n",i-m+1);
			return;			
		}								
	}
	printf("-1\n");
	return;	
}
int main(int argc, char *argv[]){
	int cas,i,j;
	scanf("%d",&cas);
	while(cas--){
		scanf("%d%d",&n,&m);
		for(i=1; i<=n;i++){
	 		scanf("%d",&a[i]);
	 	}
	 	for(i=1; i<=m;i++){
	 		scanf("%d",&b[i]);
	 	}
	 	compute();
	 	kmpmatch();
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值