Java程序练习-Ugly Numbers

描述
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n'th ugly number.

输入
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.
输出
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.
样例输入
1
2
9
0
样例输出
1
2
10
参考代码

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Iterator;
import java.util.Set;
import java.util.TreeSet;
public class Main {
	public static int N = 1601;
	public static Set<Integer> set = new TreeSet<Integer>();
	public static void main(String[] args) throws Exception, IOException{
		init();
		BufferedReader  cin = new BufferedReader (new InputStreamReader(System.in));
		while(true){
			int n = Integer.parseInt(cin.readLine());
			if(0 == n)
				break;
			System.out.println(setAt(n));
		}
	}
	private static void init() {
		set.add(1);
		int n = 1;
		int loop = 1;
		while(set.size() < N){
			add2set(n);
			n = setAt(++ loop);
		}
	}
	private static int setAt(int p) {
		int n = 0;
		Iterator<Integer> it = set.iterator();
		int j = 1;
		while(it.hasNext()){
			n = it.next();
			if(j == p)
				return n;
			j ++;
		}
		return n;
	}
	private static void add2set(int n) {
		set.add(n * 2);
		set.add(n * 3);
		set.add(n * 5);
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值