FatMouse' Trade 解题报告

原题:
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 

Sample Output
13.333
31.500
分析:
贪心算法——找最优解,我的思路是,运用结构体,运用sort函数将数据从大到小排序,先换: 7  2; 再换 5 2;最后用剩下的1个,换1.33的javabeen。
,然后问题就迎刃而解了。。
源码:
#include<algorithm>
#include<iostream>
#include<stdio.h>
using namespace std;//一些c++头文件,刚刚跟师哥学习的
struct node
{
    int x;
    int y;
    double z;
}p[1005];//this is结构体
int cmp(node a,node b)
{
    return a.z>b.z;
}
//不加这部分默认是从小到大排列
int main()
{
    int m,n,i;
    double s;
    while(scanf("%d%d",&m,&n)&&(m!=-1||n!=-1))
    {
        s=0.0;
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
            p[i].z=p[i].x*1.0/p[i].y;
        }
        sort(p,p+n,cmp);//记住这个格式————排序;
        for(i=0; i<n; i++)
        {
            if(m>=p[i].y)
            {
                s=s+p[i].x;
                m=m-p[i].y;
            }
            else
            {
                s=s+m*p[i].z;
                break;
            }
        }

        printf("%.3f\n",s);
    }
    return 0;
}
//OK

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值