SDUT——K-based Numbers

原题:

题目描述

Let’s consider K-based numbers, containing exactly N digits. We define a number to be valid if its K-based notation doesn’t contain two successive zeros. For example:
(1)1010230 is a valid 7-digit number;
(2)1000198 is not a valid number;
(3)0001235 is not a 7-digit number, it is a 4-digit number.
Given two numbers N and K, you are to calculate an amount of valid K based numbers, containing N digits.
You may assume that 2 ≤ K ≤ 10; N ≥ 2; N + K ≤ 18.

输入

The numbers N and K in decimal notation separated by the line break.

输出

The result in decimal notation.

示例输入

2 10

示例输出

90

 

分析:

递推,哎呀,如果我自己递推,肯定哇。

原码;

#include <iostream>
using namespace std;
const int maxn=20;
long long f[maxn],n,k;
int main()
{

    while(cin>>n>>k)
    {
        if(n==1)
        {
            cout<<k<<endl;
            return 0;
        }
        f[1]=k-1;
        f[2]=k*(k-1);
        for( int i=3; i<=n; i++)
        {
            f[i]=(f[i-1]+f[i-2])*(k-1);
        }
        cout<<f[n]<<endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值