Compression

原题:

Description

  Let Compression of an integer  a be the sum of all digits of  a and yields another positive integer. It is obvious that if we compress a number for certain finite steps, we will reach a one digit number. You are given a positive integer a and you are asked to output a one digit number which is created by compression of a.
For instance, if you are given a number 86, after one step of compression, we will reach number 8+6=14 , and after another step of compression, we reach 1+4=5. So, you should write  5 to the output.

Input

The number of test cases comes in the first line.  For each test case you are given a positive integer a<=2^31-1

Output

For each test case, write one digit number that you will reach after some steps of compression.

Sample Input

34311157871

Sample Output

731

 

分析:

简单数学题~~

源码:

#include<stdio.h>
int main()
{
	long long k,m,n;
	scanf("%lld",&k);
	while(k--)
	{
		scanf("%lld",&m);
		while(m/10!=0)
		{
			n=m%10;
			m/=10;
			m+=n;
		}
		printf("%lld\n",m);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值