九度oj 题目1042:Coincidence

题目描述:

Find a longest common subsequence of two strings.

输入:

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出:

For each case, output k – the length of a longest common subsequence in one line.

样例输入:
abcd
cxbydz
样例输出:
2

动态规划求LCS

#include<iostream>
#include<string>
#include<algorithm>

using namespace std;

int dp[101][101]; //dp[i][j]保存s1前i个字符与s2前j个字符的 LCS
    
int main()
{  
    string s1, s2;
    while (cin >> s1 >> s2) {
          int len1 = s1.size();
          int len2 = s2.size();
       for (int i=0; i<=len1; ++i)
            dp[i][0] = 0;
       for (int j=0; j<=len2; ++j)
            dp[0][j] = 0;
       
       for (int i=1; i<=len1; ++i) 
           for (int j=1; j<=len2; ++j) 
               if (s1[i-1] != s2[j-1]) //s1第i个字符与s2第j个字符不等 
                  dp[i][j] = max (dp[i][j-1], dp[i-1][j]);
               else
                  dp[i][j] = dp[i-1][j-1] + 1; //相等长度加1 
       cout << dp[len1][len2] << endl;
    }//while 
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值