PAT 1040. Longest Symmetric String (25)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11

思路:直接遍历所有子串,再判断是否是对称字符串,取最长对称子串

#include <string>
#include <iostream>
#include <algorithm>

using namespace std;

int main()
{
	string str, st;
	getline(cin, str);
	int ans = 0;
	for (int i=0; i<=str.size()-1; ++i) 
		for (int j=1; j<=str.size()-i; ++j) { //遍历所有子串
		    st = str.substr(i, j);
	        string s1 = st;
	        reverse(st.begin(), st.end());   //检查是否对称
	        if (st == s1 && st.size() > ans)
		        ans = st.size();
		}
	cout << ans << endl;
	//system("pause");
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值