PAT 1077. Kuchiguse (20)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

    Sample Input 1:
    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    
    Sample Output 1:
    nyan~
    
    Sample Input 2:
    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    
    Sample Output 2:
    nai
    
    思路:题目就是要找全部字符串的最长后缀,没有就输出nai,可以先把全部字符串后端对齐,然后顺序判断即可。
    
    
    #include <string>
    #include <algorithm>
    #include <iostream>
    #include <vector>
    
    using namespace std;
    
    int main()
    {
       int n;
       cin >> n;
       cin.get(); //注意这里要把空行“吃”掉,不然调用getline会读入空行
       vector<string> vs(n);
       int msize = 300;  //只要判断到最短字符串的长度即可
       for (int i=0; i!=n; ++i) {
    	   getline(cin, vs[i]);
    	   if (vs[i].size() < msize)
    		   msize = vs[i].size();
    	   reverse(vs[i].begin(), vs[i].end()); //反转以右端对齐
       }
       string s;
       int i, j;
       char c;
       for (i=0; i!=msize; ++i) {
    	  c = vs[0][i];
    	  for (j=1; j!=n; ++j) //遍历其它字符串的i位置字符
    		 if (vs[j][i] != c)  
    			 break;
    	  if (j == n)  //当当前i的字符全部都相同,加入共同后缀
    		 s += c;
    	  else
    		 break;
       }
       if (s != "") {
    	   reverse(s.begin(), s.end()); //最后变回原来顺序
    	   cout << s << endl;
       }else 
           cout << "nai" << endl;
       //system("pause");
       return 0;
    }



     
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值