【HDU】1562 Guess the number

Problem Description
Happy new year to everybody!
Now, I want you to guess a minimum number x betwwn 1000 and 9999 to let 
(1) x % a = 0;
(2) (x+1) % b = 0;
(3) (x+2) % c = 0;
and a, b, c are integers between 1 and 100.
Given a,b,c, tell me what is the number of x ?
Input
The number of test cases c is in the first line of input, then c test cases followed.every test contains three integers a, b, c.
Output
For each test case your program should output one line with the minimal number x, you should remember that x is between 1000 and 9999. If there is no answer for x, output "Impossible".

Sample Input
 
 
2 44 38 49 25 56 3
Sample Output
 
 
Impossible 2575
 
    代码:

#include <stdio.h>

int main() {
    int n,a,b,c,i;
    scanf("%d",&n);
    while (n--) {
        scanf("%d %d %d",&a,&b,&c);
        int flag=0;
        for ( i=1000; i<=9999; i++) {
            if (i%a==0&&(i+1)%b==0&&(i+2)%c==0) {
                printf("%d\n",i);
                flag=1;
                break;
            }
        }
        if (flag==0) {
            printf("Impossible\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值