2018ccpc吉林 A:THE FOOL(打表找规律)

问题 A: THE FOOL

时间限制: 1 Sec  内存限制: 128 MB
提交: 255  解决: 107
[提交] [状态] [命题人:admin]

题目描述

The Fool is numbered 0 the number of unlimited potential -and therefore does not have a specific place in the sequence of the Tarot cards . The Fool can be placed either at the beginning of the Marjor Arcam or at the end. The Major Arcana is often considered as the Fool's journey through life and as such, he is ever present and therefore needs no number.

Given n∈N+, print the parity of

where 

 

输入

The first line of the input contains one integer T≤100, denoting the number of testcases. Then T testcases follow.
In each of the T testcases, there is a positive number n≤109

 

输出

For each testcase, print a single line starting with “Case i:”( i indicates the case number) and then "even" or “odd’', separated with a single space.

 

样例输入

复制样例数据

3
1
10000
100000000

样例输出

Case 1: odd
Case 2: even
Case 3: even

(打一下表,很容易就看出来,前3个都为奇,接着5个都为偶,接着7个都为奇,接着9个都为偶,...。很明显为一个首项为3,公差为2的等差数列。我们可以利用等差数列的求和公式,设出方程为(3+2*k+1)*k/2=n,我们可以利用一元二次方程求解公式得到k=ceil(sqrt(1.0+n)-1.0)。(这里向上取整是因为如果n不是恰好前k项的和,那么给出的n肯定属于下一项。)根据规律,若k为奇数,则为odd;若k为偶数,则为even。)

#include <bits/stdc++.h>
using namespace std;
int main(void)
{
 
    int t;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        double n;
        scanf("%lf",&n);
        int k=ceil(sqrt(1.0+n)-1.0);
        printf("Case %d: ",cas);
        if(k&1)
            printf("odd\n");
        else
            printf("even\n");
         
         
    }
    return 0;
     
}

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值