2018CCPC吉林赛区(重现赛)- 1001 The Fool

Problem Description

The Fool is numbered 0 – the number of unlimited potential –and therefore does not have a specific place in the sequence of the Tarot cards. The Fool can be placed either at the beginning of the Major Arcana or at the end. The Major Arcana is often considered as the Fool’s journey through life and as such, he is
ever present and therefore needs no number.


Given n ∈ N+ , print the parity of

∑i=1N [ni ],


where [x] = max a (a∈Z,a≤x)

Input

The first line of the input contains one integer T ≤ 100, denoting the number of testcases. Then T testcases follow.
In each of the T testcases, there is a positive number n ≤ 109 .

Output

For each testcase, print a single line starting with “Case i : ”(i indicates the case number) and then “even” or “odd”, separated with a single space.

Sample Input

3

1

10000

100000000

Sample Output

Case 1: odd

Case 2: even

Case 3: even

【题解】

打个表找个规律就行

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int main()
{
     int t,n;
    scanf("%d",&t);
    for(int k=1;k<=t;k++){
        scanf("%d",&n);
        int ans=sqrt(n);
        if(ans%2==1) printf("Case %d: odd\n",k);
        else printf("Case %d: even\n",k);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值