POJ - 3494 Largest Submatrix of All 1’s

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ mn ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on mlines each with n numbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4

(题意:求出一个最大全为1的子矩阵的面积。)

(思路:枚举每一行,用单调栈正序和倒序递增维护每一列的“高度”,用l和r数组记下能到达的列,取最大值即可。)

#include <iostream>
#include <cstdio>
using namespace std;
const int N = 2e3+10;
int h[N],l[N],r[N],sta[N],top;
int n,m;
int main(void)
{
	while(~scanf("%d%d",&n,&m))	
	{
		int x,ans=0;
		for(int i=1;i<=m;i++) h[i]=0;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				scanf("%d",&x);
				h[j]=x?h[j]+1:0;
			}
			//cout<<"-------------------"<<i<<endl;
			top=0;
			for(int k=1;k<=m;k++)
			{
				while(top>0&&h[sta[top]]>=h[k])	
					top--;
				if(top==0) l[k]=1;
				else l[k]=sta[top]+1;
				sta[++top]=k;
			}
			top=0;
			for(int k=m;k>0;k--)
			{
				while(top>0&&h[sta[top]]>=h[k])	
					top--;
				if(top==0) r[k]=n;
				else r[k]=sta[top]-1;
				sta[++top]=k;
			}
			
			for(int k=1;k<=m;k++)
			{
				ans=max(ans,h[k]*(r[k]-l[k]+1));
			//	cout<<k<<" "<<h[k]<<" "<<l[k]<<" "<<r[k]<<endl;
			}
				
		}
		printf("%d\n",ans);
	}	
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值