Largest Submatrix of All 1’s(单调栈)

Description
Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input
The input contains multiple test cases. Each test case begins with m and n (1 ≤ m, n ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.

Output
For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input
2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output
0
4

Source
POJ Founder Monthly Contest – 2008.01.31, xfxyjwf

思路
将每一行的矩阵视为其在该层的高度,对矩阵进行初始化,

0 1 0 1 0
0 0 1 1 1
0 1 1 0 1
可化为
0 1 0 1 0
0 0 1 2 1
0 1 2 0 2
即可通过单调栈推出每层矩阵的最大面积

代码实现

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>


using namespace std;
typedef long long ll;
const int N=2005;
int n,m;
int h[N],s[N];
stack<int>l;
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int ans=0;
        memset(h,0,sizeof(h));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                int tmp;
                scanf("%d",&tmp);
                if(tmp) h[j]++;
                else h[j]=0;
                s[j]=h[j];
            }
            s[m]=-1;
            for(int j=0;j<=m;j++)
            {
                if(l.empty() || s[l.top()]<=s[j])
                {
                    l.push(j);
                }
                else
                {
                    int top;
                    while(!l.empty() && s[l.top()]>s[j])
                    {
                        top=l.top();
                        ans=max(ans,(j-top)*s[top]);
                        l.pop();
                    }
                    l.push(top);
                    s[top]=s[j];
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值