LightOJ - 1245 Harmonic Number (II) (除法分块)

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        res = res + n / i;
    return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386

 

 

对于\left \lfloor \frac{n}{i}\right \rfloor,显然有些i的结果是一样的,也就是说可以把[1,n]分成若干区间,每个区间得到的结果是一样的.假设左端点为l,那么右端点就是\left \lfloor \frac{n}{\left \lfloor \frac{n}{i} \right \rfloor} \right \rfloor。(证明参考博客:https://www.cnblogs.com/SGCollin/p/9630478.html)那么,就从1开始,加上每个区间的值就可以了。

#include <bits/stdc++.h>
#define ll long long
using namespace std;
int main(void)
{
	int t,tt=0;
	scanf("%d",&t);
	while(t--)
	{
		ll n;
		scanf("%lld",&n);
		ll ans=0,r;
		for(ll l=1;l<=n;l=r+1)
		{
			r=min(n/(n/l),n);
			ans+=(r-l+1)*(n/l);	
		}
		printf("Case %d: %lld\n",++tt,ans);
	}
	return 0;
}

/*
11
1
2
3
4
5
6
7
8
9
10
2147483647
*/

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值