[poj2777 Count Color]线段树

Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36607 Accepted: 11047

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source

POJ Monthly--2006.03.26,dodo

很明显的线段树,并且需要lazy操作提高性能,同时,注意到题目中的颜色数量很少,所以可以用一个整数表示一个集合,维护的是结点所管辖区间包含的所有颜色。
2777Accepted6496K282MSG++2900B
代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAX = 100007;
struct Node {
	int L, R;	//区间 
	int left, right;	//左右孩纸 
	int color;//每个节点的color包含了该结点所管理区间的颜色信息 
	bool lazy;
} tree[MAX << 2];
int N, C, M;

/*
	位运算大法好,因为颜色最多30种,可以用32位int表示出来。
	每个区间包含的颜色就直接采用二进制记录
	修改时修改孩子后把自身的颜色设为lson.color | rson.color
	也就是包含左右孩子的全部颜色
	查询时也可以直接用位运算返回左右孩子的color的或 
*/ 
//建树 
void build(int root, int L, int R) {
	if (L == R) {
		tree[root].L = tree[root].R = L;
		tree[root].color = 2;
		tree[root].lazy = false;
		return;
	}
	tree[root].L = L, tree[root].R = R;
	tree[root].left = root << 1;
	tree[root].right = tree[root].left | 1;
	tree[root].color = 2;
	tree[root].lazy = false;
	int mid = (L + R) >> 1;
	build(tree[root].left, L, mid);
	build(tree[root].right, mid + 1, R);
}

//下放操作 
void pushdown(int root) {
	if (tree[root].lazy && tree[root].R > tree[root].L) {
		tree[root].lazy = false;
		int ls = tree[root].left;
		int rs = tree[root].right;
		tree[ls].lazy = tree[rs].lazy = true;
		tree[ls].color = tree[rs].color = tree[root].color;
	}
}

//修改颜色 
void modify(int root, int L, int R, int cool) {
	//printf("modify %d,%d,%d,%d\n", root, L, R, cool);
	//如果区间被完全覆盖,采用lazy操作,在父节点处设置lazy 
	if (L <= tree[root].L && R >= tree[root].R) {
		tree[root].lazy = true;
		tree[root].color = cool;
		return;
	} else if (L > tree[root].R || R < tree[root].L) return;
	//否则,下放后修改左右孩纸,并修改父节点的颜色。 
	if (tree[root].lazy) pushdown(root);
	modify(tree[root].left, L, R, cool);
	modify(tree[root].right, L, R, cool);
	tree[root].color = tree[tree[root].left].color | tree[tree[root].right].color;
}

int query(int root, int L, int R) {
	//printf("query %d,%d,%d\n", root, L, R);
	if (L <= tree[root].L && R >= tree[root].R) {
		return tree[root].color;
	} else if (L > tree[root].R || R < tree[root].L) return 0;
	pushdown(root);//下放 
	return query(tree[root].left, L, R) | query(tree[root].right, L, R);
}

inline int read() {
	char ch;
	while ((ch = getchar()) < '0' || ch > '9');
	int x = ch - '0';
	while ((ch = getchar()) >= '0' && ch <= '9') {
		x = (x << 3) + (x << 1) + ch - '0';
	}
	return x;
}

void Print(int x) {
	if (x == 0) return;
	Print(x / 10);
	putchar(x % 10 + '0');
}

int main() {
	while (~scanf(" %d %d %d", &N, &C, &M)) {
		build(1, 1, N);
		char op;
		int l, r, c;
		for (int i = 0; i < M; ++i) {
			while ((op = getchar()) != 'P' && op != 'C');
			l = read();
			r = read();
			//scanf(" %c %d %d", &op, &l, &r);
			if (l > r) swap(l, r);
			if (op == 'C') {
				c = read();
				//scanf(" %d", &c);
				modify(1, l, r, 1 << c);
			} else {
				int tmp = query(1, l, r);\
				int s = 0;
				while (tmp) {
					s += tmp & 1;
					tmp >>= 1;
				}//取出tmp二进制中1的个数 
				Print(s); //printf("%d\n", s);
				putchar('\n');
			}
		}
	}
	return 0;
}

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值