[toj1075]Stockbroker Grapevine

1075.   Stockbroker Grapevine
Time Limit: 1.0 Seconds    Memory Limit:65536K
Total Runs: 831    Accepted Runs:515



Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their 'trusted sources'. This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input file is terminated by a set of stockbrokers containing 0 (zero) people.

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output
3 2
3 10


Source: Southern African 2001

题意:给定N个股票经纪人以及和其它人中“亲近”的关系,每个人只相信和自己关系好的人的消息。如

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
表示3个人,第一个人
2 2 4 3 5
和另2个人较“亲近”,分别为2,距离4,以及3号,距离5.以此类推。

问选取某一个人作为起点,向他散播消息,使所有人都知道这个消息的时间最短。

tip1:A到B的距离不一定等于B到A的距离

tip2:可能存在孤立点,即:某个人和别人没有任何关系。

这题数据范围很小,所以可以暴力一点做,枚举n个人作为起点,首先可以BFS判断一下从改点出发是否所有人都可达,复杂度O(E*V),当然并查集也是可以的,复杂度好一些O(E)。然后如果所有人都可达,就可以跑一遍单源最短路,注意本例是有向图,所以更新时要单向更新。如果不存在这样的点,输出disjoint。

代码

#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;

const int INF = 0xfffffff;
const int MAX = 107;
bool vis[MAX];
int cost[MAX];
struct Node {
	int to;
	int flow;
};
vector<Node> G[MAX];
int n;

bool BFS(int u) {
	memset(vis, false, sizeof(vis));
	vis[u] = true;
	
	queue<int> Q;
	int p = u;
	Q.push(u);
	int sum = 1;
	while (!Q.empty()) {
		p = Q.front();
		Q.pop();
		for (vector<Node>::iterator e = G[p].begin(); e != G[p].end(); ++e) {
			if (!vis[e->to]) {
				vis[e->to] = true;
				Q.push(e->to);
				++sum;
			}
		}
	}
	return sum == n;
}

int dijistra(int u) {
	fill(cost, cost + n + 1, INF);
	cost[u] = 0;
	memset(vis, false, sizeof(vis));
	int ret = 0;
	while (true) {
		int v = -1;
		for (int u = 1; u <= n; ++u) {
			if (!vis[u] && (v == -1 || cost[u] < cost[v])) {
				v = u;
			}
		}
		if (v == -1) break;
		
		vis[v] = true;
		if (cost[v] > ret) ret = cost[v];
		
		for (vector<Node>::iterator e = G[v].begin(); e != G[v].end(); ++e) {
			if (cost[e->to] > cost[v] + e->flow) {
				cost[e->to] = cost[v] + e->flow;
			}
		}
	}
	return ret;
}

int main() {
	while (~scanf(" %d", &n) && n) {
		int m;
		Node v;
		for (int i = 1; i <= n; ++i) {
			G[i].clear();
			scanf(" %d", &m);
			while (m--) {
				scanf(" %d %d", &v.to, &v.flow);
				G[i].push_back(v);
			}
		}
		
		pair<int, int> ans = make_pair(-1, INF);
		for (int i = 1; i <= n; ++i) {
			if (BFS(i)) {
				int JBer = dijistra(i);
				if (ans.first == -1 || JBer < ans.second) {
					ans.first = i;
					ans.second = JBer;
				}
			}
		}
		if (~ans.first) {
			printf("%d %d\n", ans.first, ans.second);
		} else {
			puts("disjoint");
		}
	}
	return 0;
}

注:pair在头文件utility中,如果编译不过的话。。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值