HDU How many prime numbers

Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.
 
Output

            For each case, print the number of prime numbers you have found out.


Sample Input
3
2 3 4
 
Sample Output
2
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int is_primer(int n)
{
    int i, num ;
    num = floor(sqrt(n) + 0.5);
    for(i = 2; i <= num; i++)
        if(n % i == 0) return 0;
    return 1;
}
int main(void)
{
   int n, i, count;
   while(scanf("%d", &n) != EOF){
        count = 0;
        for(i = 1; i <= n; i++){
            long long int num;
            scanf("%lld", &num);
            int val = is_primer(num);
            if(val) count++;
        }
            printf("%d\n", count);
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值