HDU 2138 How many prime numbers【素数判断,卡时间!!】

33 篇文章 0 订阅

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14873 Accepted Submission(s): 5150


Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.

Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.

Output
For each case, print the number of prime numbers you have found out.

Sample Input
  
  
3 2 3 4

Sample Output
  
  
2


记得一次周赛做到这道题,发现一直TLE....后来用最保险的,最低级的方法做,才AC.当场感觉自己那些什么快速判断素数的方法白学了............

这一次在做,发现:i*i 这个条件用上都会超时,真是卡系数啊...........

以后还是多注意点吧,要不然会做的还是wa,养成个好习惯还是比较好的...........


#include<stdio.h>
#include<math.h>
int is_prime(int x)
{
	int tp=(int)sqrt(x*1.0);
	for(int i=2;i<=tp;++i)
	{
		if(x%i==0)
		{
			return 0;
		}
	}
	return 1;
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		int ans=0,tp;
		for(int i=0;i<n;++i)
		{
			scanf("%d",&tp);
			if(tp==2)
			{
				++ans;
			}
			else if(tp&1)
			{
				ans+=is_prime(tp);
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值