素数环

A ring is composed of n (even number) circles as shown in diagram.Put natural numbers 1, 2, . . . , n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.Note: the number of first circle should always be 1.

 Input 

n (0 < n ≤ 16)

Output 

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clock wisely and anti clock wisely. The order of numbers must satisfy the above requirements. You are to write a program that completes above process.

Sample Input

6

8

Sample Output

Case 1:

1 4 3 2 5 6

1 6 5 2 3 4


Case 2:

1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2


链接:https://vjudge.net/contest/227390#problem/D

题意:
输入正整数n,把整数1,2,3,...,n组成一个环,使得相邻两个帧数之和均为素数。
思路:
利用DFS,进行回溯。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,a[40],vis[30],b[30],k=1;
int su(int n)
{
    for(int i=2;i<n;i++)
    if(n%i==0) return 0;
    return 1;
}
void dfs(int x)
{
    if(x==n)
    {
        if(a[b[x-1]+1])
        {
            cout<<b[0];
            for(int i=1;i<n;i++)
            cout<<" "<<b[i];
            cout<<endl;
        }
    }
    else
    {
        for(int i=2;i<=n;i++)
        {
            if(!vis[i]&&a[i+b[x-1]])
            {
                b[x]=i;
                vis[i]=1;
                dfs(x+1);
                vis[i]=0;
            }
        }
    }
}
int main()
{
    for(int i=0;i<40;i++)
       a[i]=su(i);
    b[0]=1;
    while(cin>>n)
    {
        if(k>1) cout<<endl;
        cout<<"Case "<<k<<":"<<endl;
        k++;
         memset(vis, 0, sizeof(vis));
      dfs(1);


    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值