hdu 1052 Tian Ji -- The Horse Racing(一组很好的测试数据)

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6786 Accepted Submission(s): 1644
 

Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

 

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

 

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

 

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

 

Sample Output

200
0
0

 

 

Source

2004 Asia Regional Shanghai

1.当田忌最慢的马比齐王最慢的马快,赢一场先。因为始终要赢齐王最慢的马,不如用最没用的马来赢它。
2.当田忌最慢的马比齐王最慢的马慢,和齐王最快的马比,输一场。因为田忌最慢的马始终要输的,不如用它来消耗齐王最有用的马。
3.当田忌最慢的和齐王最慢的马慢相等时,分4和5讨论。
4.当田忌最快的马比齐王最快的马快时,赢一场先。因为最快的马的用途就是来赢别人快的马,别人慢的马什么马都能赢。
5.当田忌最快的马比齐王最快的马慢时,拿最慢的马和齐王最快的马比,输一场,因为反正要输一场,不如拿最没用的马输。
6.当田忌最快的马和齐王最快的马相等时,这就要展开讨论了,贪心方法是,拿最慢的马来和齐王最快的马比.

这一题基本网上的题解很详细,但几乎没有分析为什么下面思路错误。

1、田忌的快马比齐王的快,直接比掉。 
2、若快马没有快,就拿田忌最慢的和齐王最快的比较。

给一组测试数据

3

99 99 2

99 98 1

可以看出用第二种贪心:

King  99-> tianji 2

King 98-> tianji 99

King 1->tianji 99

赢200

但用第一种贪心会得到400

因为第二种只考虑让tianji快马祈祷更大作用,没考虑到King的很慢马起到消耗tianji次慢马的结果。导致不是最优解。

可以根据这组数据和上面网上的解析仔细思考下,很容易得到贪心最优解。(当然第一种贪心先比快马然后比慢马也可以的)

AC代码

#include<cstdio>
#include<algorithm>
using namespace std;
int a[1010];
int b[1010];
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int n;
	while(scanf("%d",&n)&&n)
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&b[i]);
		}
		sort(a+1,a+1+n,cmp);
		sort(b+1,b+1+n,cmp);
		int sum=0;
		int i=1,j=1,io=n,jo=n,flag=0;//flag为参与比赛马的对数,i,io,j,jo分别为tianji  king的快慢马
		while(1)
		{
			if(flag==n)break;
			if(a[i]>b[j])
			{
				sum+=200;
				i++;j++;
				flag++;
				continue;
			}	
	        if(a[i]<=b[j])
			{
				  if(a[io]>b[jo])
				  {
					  sum+=200;
					  io--;jo--;flag++;
					  continue;
				  }
				  if(a[io]<=b[jo])
				  {
					  if(a[io]<b[j])
					  {
						  sum-=200;
						  flag++;
					      j++;io--;
					      continue;
					  }
					  if(a[io]==b[j])
					  {
						  j++;io--;
						  flag++;
					      continue;
					  }
				  }
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

 

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值