HDU 1062 Text Reverse(栈的应用)—— C++

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

题意:翻转字符串。例如输入 “olleh !dlrow” ,输出 “hello world!” 。

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output

hello world!
I’m from hdu.
I like acm.

代码

#include <stack>
#include<iostream>
#include<string>
using namespace std;
int main() {
	int n;
	cin >> n;getchar();                  // 获取 ‘\n’ ,避免其影响 getline()
	while (n--) {
		stack<char>c;                    // 栈的声明
		string a;getline(cin, a);
		for (int i = 0; i < a.length(); i++) {
			if (a[i] != ' ') {
				c.push(a[i]);            //入栈
				if (i == a.length() - 1) {
					while (!c.empty()) {
						cout << c.top(); //输出栈顶
						c.pop();        //清除栈顶
					}
				}
			}
			else {
				while (!c.empty()) {
					cout << c.top();
					c.pop();
				}
				cout << " ";
			}
		}
		cout << endl;
	}	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值