【数学】Ignatius's puzzle

描述

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5x13+13*x5+ka*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print “no”.

输入

The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

输出

The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.

样例输入

11
100
9999

样例输出

22
no
43

题目来源

HDOJ

分析:
1、f(x)为65的倍数,知k求a 18+ka=65 满足18%gcd(k,65)=0
2、展开f(x+1)与f(x)处理。
代码:
#include<bits/stdc++.h>
using namespace std;
int gcd(int x,int y)
{
int z;
if (x<y) swap(x,y);
while(y>0)
{
z=y;
y=x%y;
x=z;
}
return z;
}
int main()
{
int k;
while(cin>>k)
{
if (18%gcd(k,65)==0)
{
for (int i=0;;i++)
{
int d=i
k+18;
if (d%65==0)
{
cout<<i<<endl;
break;
}
}
}
else
cout<<“no”<<endl;
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值