POJ 1703 并查集

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
   

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.



题意:t个测试样例,每个测试样例有n个强盗,m个询问。A X Y,询问x和y是否在同一个团伙,D X Y,表示X和Y不在同一个团伙。


方法:并查集的偏移,具体思想请见日志POJ-1182


注意:题中有两个强盗团伙,每个团伙保证不为空,所以当n等于2时,直接询问A 1 2输出的应该是different,不应该是not sure。



#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
	int par,rel;
}e[100005];
int findroot(int x){
	if(x==e[x].par)return x;
	int temp=e[x].par;
	e[x].par=findroot(temp);
	e[x].rel=(e[x].rel+e[temp].rel)%2;
	return e[x].par;
}
int main(){
	int t,i,n,m,x,y;
	scanf("%d",&t);
	char c[3];
	while(t--){
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++){
			e[i].par=i;
			e[i].rel=0;
		}
		for(i=1;i<=m;i++){
			scanf("%s",c);
			scanf("%d%d",&x,&y);
			if(c[0]=='A'){
				if(n==2){
					if(x==y)printf("In the same gang.\n");
					else printf("In different gangs.\n");
					continue;
				}
				int root1=findroot(x);
				int root2=findroot(y);
				if(root1!=root2){
					printf("Not sure yet.\n");
				}
				else{
					if((2-e[x].rel+e[y].rel)%2==1){
						printf("In different gangs.\n");
					}
					else{
						printf("In the same gang.\n");
					}
				}
			}
			else{
				int root1=findroot(x);
				int root2=findroot(y);
				if(root1!=root2){
					e[root2].par=root1;
					e[root2].rel=(e[x].rel+1+2-e[y].rel)%2;
				}
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值