poj1703(并查集)

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24900 Accepted: 7482

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2.A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.
本题是并查集的拓展运用,A [a] [b] 表示询问a与b的关系,D [a] [b] 表示a与b属于不同的帮派
1、当指令为A [a] [b]时,首先查找a,b是否属于同一集合,若不是,则直接输出Not sure yet.若是则判断a与b的关系,视情况输出结果
2、当指令为D [a] [b]时,将a与b合并入同一集合,并建立属于不同集合的关系
 
par[a]存放a的父亲节点,relation[a]表示a与其父亲节点的关系(relation[a]为0表示a与其父亲节点的关系为同一帮派,为1表示a与其父亲节点的关系为不同帮派),注意关系的传递性,对2取模
初始化为par[a]=a,relation[a]=0
 
#include<iostream>
#include<cstdio>
using namespace std;
int const MAX=500000+20;


int n,m;
int par[MAX];
int relation[MAX];
//0表示与其父亲节点属于同意帮派,1表示属于不同帮派

int Get_par(int a)
//查找a的父亲节点并压缩路径,
{
	if(par[a]==a)
		return par[a];
	//注意语句的顺序
	int pa=par[a];
	par[a]=Get_par(par[a]);
	relation[a]=(relation[a]+relation[pa])%2;//a与根节点的关系可通过a与其父亲节点以及其父亲节点与根节点的关系来唯一确定,
	return par[a];
}


void Merge(int a,int b)
//合并a,b
{
	int pa,pb;
	pa=Get_par(a);
	pb=Get_par(b);
	par[pa]=pb;
	relation[pa]=(1+relation[a]+relation[b])%2;//通过a与其根节点以及b与其根节点以及a与b的关系建立a的根节点与b的跟节点的关系
}

int main()
{
	int cas,i;
	int a,b,pa,pb;
	cin>>cas;
	while(cas--)
	{
		char cmd[10];
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
		{
			par[i]=i;
			relation[i]=0;
		}
		
		for(i=0;i<m;i++)
		{
			scanf("%s%d%d",cmd,&a,&b);
			if(cmd[0]=='D')
			{
				Merge(a,b);
				continue;
			}
			else
			{
				pa=Get_par(a);
				pb=Get_par(b);
				if(pa==pb)
				{
					if((relation[a]+relation[b])%2==0)
					{
						printf("In the same gang.\n");
						continue;
					}
					else
					{
						printf("In different gangs.\n");
						continue;
					}
				}
				else 
				{
					printf("Not sure yet.\n");
					continue;
				}
			}
		}
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值