Antenna Placement--匈牙利算法

Antenna Placement
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8618 Accepted: 4269

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5


题目链接:http://poj.org/problem?id=3020


神烦,上来都没有想到这是个二分图的题,我这么渣可怎么办啊。。

题目的意思是说一个矩形中,有N个城市’*’,现在这n个城市都要覆盖无线,若放置一个基站,那么它至多可以覆盖相邻的两个城市。问至少放置多少个基站才能使得所有的城市都覆盖无线?看好题哦,*是城市,o是空地,不要被题目中的图片误导。

那么可以显然的想的这是一个最小覆盖的问题,好吧,显然是想不到的,+_+||,不要在意这么尴尬的细节,我们接着往下说,既然是最小覆盖问题,那么就要讨论这是无向图还是有向图,这个很重要,然后本题的最大难点来了,建图,这个图不好建,直接上链接,写的很棒很明白http://blog.csdn.net/lyy289065406/article/details/6647040

哎,渣渣我可该怎么办啊!!

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int map1[1000][1000];
int link[1000];
int use[1000];
int xin[1000][1000];
int disx[4]={1,0,-1,0};
int disy[4]={0,1,0,-1};
int top;
int DFS(int x)//匈牙利算法
{
    int i;
    for(i=1;i<=top;i++)
    {
        if(xin[x][i]&&!use[i])
        {
            use[i]=1;
            if(!link[i]||DFS(link[i]))
            {
                link[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        memset(xin,0,sizeof(xin));//城市
        memset(map1,0,sizeof(map1));
        memset(link,0,sizeof(link));
        top=0;
        scanf("%d%d\n",&n,&m);
        int i,j;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                char c;
                scanf("%c",&c);
                if(c=='*')
                    map1[i][j]=++top;//注意,此处写top++时,下面所有要用top的地方要减一
            }
            getchar();
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                if(map1[i][j])
                {
                    for(int k=0;k<4;k++)
                    {
                        int x=disx[k]+i;
                        int y=disy[k]+j;
                        if(map1[x][y])
                            xin[map1[i][j]][map1[x][y]]=1;
                    }
                }
            }
        }
        int ans=0;
        for(i=1;i<=top;i++)//板子
        {
            memset(use,0,sizeof(use));
            int h=DFS(i);
            if(h)
                ans++;
        }
        cout<<top-ans/2<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值