Snowflake Snow Snowflakes----查找

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 38352 Accepted: 10054

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.
题目链接:http://poj.org/problem?id=3349

这个题可算是整死我了,我和柏皓整了两个小时,我的天那,一直想偷懒找种快的方法过,但是。。。果然,这个世界上并没有什么捷径可以走的,早来得迟早要还。

题目的意思大致是有n片雪花,每片雪花有六条边,让你判断有没有两片雪花完全相同。

注意,要考虑逆时针和顺时针两种方向,也就是说一共有12种情况。

我这里用代码讲思路吧。

代码:

#include <cstdio>
#include <algorithm>
using namespace std;
struct node
{
	int a[10];
} xin[233333], d[12];
int cmp(struct node a, struct node b)//排序加比较
{
	int i = 0;
	while (i < 6 && a.a[i] == b.a[i])//找到第一个不想等的地方
		i++;
	if (i < 6)
		if (a.a[i] < b.a[i])//字典序排列
			return 1;
		else if (a.a[i] > b.a[i])
			return 0;
	return 2;//比较
}
int main()
{
	int n,s[10],i,j;
	while (~scanf("%d", &n))
	{
		for (i = 0; i < n; i++)
		{
			int maxc =  0x3f3f3f3f, k;
			for (j = 1; j <= 6; j++)
			{
				scanf("%d", &s[j]);//临时数组
				if (s[j] < maxc)
				{
					maxc = s[j];//找到最小值
					k = j;//记录位置
				}
			}
			int t = 0;
			for (int k = 1; k <= 6; k++)//判断12种情况
			{
				if (s[k] == maxc)
				{
					int top = 0;
					for (j = k; j >= 1; j--)
						d[t].a[top++] = s[j];
					for (j = 6; j > k; j--)
						d[t].a[top++] = s[j];
					t++;
					top = 0;
					for (j = k; j <= 6; j++)
						d[t].a[top++] = s[j];
					for (j = 1; j < k; j++)
						d[t].a[top++] = s[j];
					t++;
				}
			}
			sort(d, d + t, cmp);//找到字典序最小的那一组
			xin[i] = d[0];
		}
		sort(xin, xin + n, cmp);//按照字典序排序
		for (i = 0; i < n - 1; i++)
		{
			if (cmp(xin[i], xin[i + 1]) == 2)
			{
				printf("Twin snowflakes found.\n");
				break;
			}
		}
		if (i == n - 1)
			printf("No two snowflakes are alike.\n");
	}
	return 0;
}

心好累,好困啊QAQ~~~


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值