[ACM] POJ 3349 Snowflake Snow Snowflakes(哈希查找,链式解决冲突)

286 篇文章 140 订阅
16 篇文章 0 订阅
Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 30512 Accepted: 8024

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source

 

解题思路:

雪花有六个角,每个角有一个长度,按顺时针或者逆时针给出,起点是随机的。两个雪花相同当且仅当每个角的长度一样,且必须是连续的,比如   2 3 1  4 5 6 和 2 1 3  4 5 6就不行,1 2 3 4 5 6    4 3 2 1 6 5是一样的(第二个逆时针给出)。给出一堆雪花的六个角的长度,问这里面能不能找到两个相同的雪花。

1. 两个雪花相同的前提条件是,它们雪花六个角的长度和相等。 把每个雪花按照长度映射到哈希表中。这里哈希表用 vector< snowflake> hs[]. 当 hs[i].size()>1时,说明hs[i][j] 和hs[i][k]有可能是两个相同的雪花,只要在hs[i]里面查找就可以了。

2. 怎么判断两个雪花a,b相同?分两步,一, 固定a,用b的每个边和a的第一条边对齐,然后顺时针比较a,b的每一条边。二,固定a,用b的每个边和a的第一条边对齐,然后逆时针比较a,b的每一条边。

Ps:以此题哀悼下考砸的数据结构。。。。考试的时候我竟然连拉链法解决冲突都不知道。。

代码:

#include <iostream>
#include <stdio.h>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=100002;
const int prime=99991;

struct SnowFlake
{
    int len[6];
}snow[maxn];

vector<SnowFlake>hs[prime];

void Hash(SnowFlake s)//映射
{
    int addr=(s.len[0]+s.len[1]+s.len[2]+s.len[3]+s.len[4]+s.len[5])%prime;
    hs[addr].push_back(s);
}

bool cmp(SnowFlake a,SnowFlake b)//比较两个雪花是否相同
{
    for(int i=0;i<6;i++)
    {
        if(a.len[0]==b.len[i]&&a.len[1]==b.len[(i+1)%6]&&a.len[2]==b.len[(i+2)%6]&&
           a.len[3]==b.len[(i+3)%6]&&a.len[4]==b.len[(i+4)%6]&&a.len[5]==b.len[(i+5)%6])
           return true;//固定a,顺时针比较
        if(a.len[0]==b.len[i]&&a.len[1]==b.len[(i+5)%6]&&a.len[2]==b.len[(i+4)%6]&&
           a.len[3]==b.len[(i+3)%6]&&a.len[4]==b.len[(i+2)%6]&&a.len[5]==b.len[(i+1)%6])
           return true;//固定a, 逆时针比较
    }
    return false;
}

int main()
{
    int n;
    scanf("%d",&n);
    SnowFlake sf;
    while(n--)
    {
        for(int i=0;i<6;i++)
            scanf("%d",&sf.len[i]);
        Hash(sf);
    }
    for(int i=0;i<prime;i++)
        if(hs[i].size()>1)//有可能有相同的雪花
    {
        for(int j=0;j<hs[i].size();j++)
            for(int k=j+1;k<hs[i].size();k++)
        {
            if(cmp(hs[i][j],hs[i][k]))
            {
                printf("Twin snowflakes found.");
                return 0;
            }
        }
    }
    printf("No two snowflakes are alike.");
    return 0;
}


 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值