Period--KMP,最小循环节

Period
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 16597 Accepted: 7976

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
题目链接:http://poj.org/problem?id=1961

我的天,KMP有这么神奇的应用,我以前竟然都没有好好的研究,以后算法要学到家啊。

熟悉KMP的都知道KMP算法中有一个next[]数组,其实这个数组可以求最小循环节,O(len)的算法,太神奇了,我这个题写了个暴力,POJ后台这个题太硬,TLE,问了金桔,然后子祥大大上来特地给我讲了一遍,万分感谢,好人啊。

这是讲解kmp求最小循环节,讲的很清楚,大神太多了。

我感觉我就直接上代码吧,上面大神已经讲的很清楚了。

代码:
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cstdlib>
#include <string>
using namespace std;
int next[1000010];
void getnext(char t[]){
    int i=0,j=-1,l;
    next[0]=-1;
    l=strlen(t);
    while(i!=l){
        if(j==-1||t[i]==t[j]){
            ++j;
            ++i;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
char s[1000010];
int main(){
    int n;
    int t=1;
    while(~scanf("%d",&n)&&n){
        scanf("%s",s);
        getnext(s);
        printf("Test case #%d\n",t++);
        for(int i=1;i<=n;i++){
            int h=i-next[i];
            if(i!=h&&i%h==0)
                printf("%d %d\n",i,i/h);
        }
        cout<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值