Power Strings - poj2406 - kmp最小循环节

Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 63047 Accepted: 26013

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01

思路:

这个题就是求最小循环节的个数,当len%(len-nex[len])==0,有最小循环节,是len-nex[len]

个数为:len/(len-nex[len])

因为如果满足len%(len-nex[len])==0,那么:

1=2

2=3

3=4

4=5

这样就找到了最小循环节

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<stack>
#include<cmath>
#include<set>
#include<map>
using namespace std;
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef pair<int,int>P;
const int INF=0x3f3f3f3f;
const int N=1000015;
char s[N];
int nex[N];
void getNext(char s[]){
    nex[0]=-1;nex[1]=0;
    int len=strlen(s);
    for(int i=2;i<=len;i++){
        int k=nex[i-1];
        while(k>=0&&s[k-1+1]!=s[i-1])k=nex[k];
        nex[i]=k+1;
    }
}

int main(){
    while(scanf("%s",s)){
        if(s[0]=='.')break;
        getNext(s);
        int len=strlen(s);
        if(len%(len-nex[len])==0)printf("%d\n",len/(len-nex[len]));
        else printf("1\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值