Power Strings--KMP,最小循环节

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 44301 Accepted: 18487

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题目链接:http://poj.org/problem?id=2406


和我上一篇博客完全一样,这就是个水题了。


代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cstdlib>
#include <string>
using namespace std;
int next[1000010];
void getnext(char t[]){
    int i=0,j=-1,l;
    next[0]=-1;
    l=strlen(t);
    while(i!=l){
        if(j==-1||t[i]==t[j]){
            ++j;
            ++i;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
char s[1000010];
int main(){
    while(~scanf("%s",s)&&*s!='.'){
        getnext(s);
        int len=strlen(s);
        if(len%(len-next[len])==0)
            printf("%d\n",len/(len-next[len]));
        else
            printf("1\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值