Nearest Common Ancestors--LCA

Nearest Common Ancestors
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26927 Accepted: 13880

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

 
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

题目链接:http://poj.org/problem?id=1330


做的第一个LCA的题,虽说没有按照题目要求来用在线算法,但是在线也是Tarjan啊,而且只有一组查询,也可以用离线啊。


题意大概是介绍了一下什么叫做最近公共祖先,然后说输入一个组数,然后输入一个节点数,然后n-1行,最后一行输入要查询的两个节点。


链上个链接,我学LCA时的链接,这一个链接就可以学会LCA离线求法。

http://www.cnblogs.com/ylfdrib/archive/2010/11/03/1867901.html

这是个离线算法,Tarjan,LCA还挺简单的。


代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <vector>
using namespace std;
const int N=100005;
int n;
vector<int> vec[N];
int pre[N];
bool vis[N];
bool root[N];
int u,v;
int Find(int x){
    return x==pre[x]?x:Find(pre[x]);
}
void mix(int x,int y){
    int xx=Find(x);
    int yy=Find(y);
    if(xx!=yy){
        pre[yy]=xx;//不可搞错顺序,xx是yy的祖先
    }
}
void Init(){
    for(int i=0;i<=n;i++){
        vec[i].clear();
        pre[i]=i;
        root[i]=true;
        vis[i]=false;
    }
}
void Tarjan(int x){
    for(int i=0;i<(int)vec[x].size();i++){
        Tarjan(vec[x][i]);
        mix(x,vec[x][i]);
    }
    vis[x]=true;
    if(u==x&&vis[v]==true){
        printf("%d\n",Find(v));
        return ;
    }
    if(v==x&&vis[u]==true){
        printf("%d\n",Find(u));
        return ;
    }
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        Init();
        for(int i=0;i<n-1;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            vec[a].push_back(b);
            root[b]=false;
        }
        scanf("%d%d",&u,&v);
        for(int i=1;i<=n;i++){
            if(root[i]==true){
                Tarjan(i);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值