Apple Tree--树形DP

Apple Tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10150 Accepted: 3374

Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input 
Each test case contains three parts. 
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200) 
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i. 
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent. 
Input will be ended by the end of file. 

Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1 
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2
题目链接:http://poj.org/problem?id=2486


Q^Q

题目大意是说一个女孩要在规定的k步内吃到最多的苹果,类似于背包,k为背包容量,苹果的个数为权值,求在规定的步数内可以获得的最大的权值。


想了一整天,总感觉就差那么一点,然后去看了题解,嗯,我还差得远呢,训练计划害死人啊,嗯,我要努力挖坑,然后埋上,哎。


大体的思路是我们很容易的就可以想到dp[root][k],表示以root为根节点在k步内可以吃到的最大苹果数,我就想到了这。。。下面开始讲大牛们的思路:

树形dp,比较经典的一个树形dp。首先很容易就可以想到用dp[root][k]表示以root为根的子树中最多走k时所能获得的最多苹果数,接下去我们很习惯地会想到将k步在root的所有子结点中分配,也就是进行一次背包,就可以得出此时状态的最优解了,但是这里还有一个问题,那就是在进行背包的时候,对于某个孩子son走完之后是否回到根结点会对后面是否还能分配有影响,为了解决这个问题,我们只需要在状态中增加一维就可以了,用dp[root][k][0]表示在子树root中最多走k步,最后还是回到root处的最大值,dp[root][k][1]表示在子树root中最多走k步,最后不回到root处的最大值。由此就可以得出状态转移方程了:

dp[root][j][0] = MAX (dp[root][j][0] , dp[root][j-k][0] + dp[son][k-2][0]);//从s出发,要回到s,需要多走两步s-t,t-s,分配给t子树k步,其他子树j-k步,都返回

dp[root][j]][1] = MAX(  dp[root][j][1] , dp[root][j-k][0] + dp[son][k-1][1]) ;//先遍历s的其他子树,回到s,遍历t子树,在当前子树t不返回,多走一步

dp[root][j][1] = MAX (dp[root][j][1] , dp[root][j-k][1] + dp[son][k-2][0]);//不回到s(去s的其他子树),在t子树返回,同样有多出两步


以上摘自ACM!荣耀之路上古大牛。这个加一步或者两步想了我半天为什么,我还是太渣了,根到孩子节点需要1步,从孩子节点算k步可以吃到最大的苹果数的时候要剪掉这一步,返回root时再加一步,所以是两步,不返回的时候才一步,总得来说:

要么去root其他子树待着,要么去root的son子树待着,要么回到root,仔细一想这一点很容易就明白。

dp[root][j][0]=max(dp[root][j][0],dp[root][j-t][1]+dp[son][t-1][0]);//先遍历s的其他子树,回到s,遍历t子树,在当前子树t不返回,多走一步

dp[root][j][0]=max(dp[root][j][0],dp[root][j-t][0]+dp[son][t-2][1]);//不回到s(去s的其他子树),在t子树返回,同样有多出两步

dp[root][j][1]=max(dp[root][j][1],dp[root][j-t][1]+dp[son][t-2][1]);//先遍历s的其他子树,回到s,遍历t子树,在当前子树t不返回,多走一步


附上两个大牛的链接:

http://blog.csdn.net/libin56842/article/details/10101807

http://www.cnblogs.com/wuyiqi/archive/2012/01/09/2316758.html

网上好多大牛用的树状数组,膜拜。。。

立志做大牛的渣渣的代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
struct node{
    int u,v,pre;
}edge[1000];
int p[300],nEdge;
int n,k;
int dp[300][500][3],a[300];
void Init(){
    memset(p,-1,sizeof(p));
    memset(dp,0,sizeof(dp));
    nEdge=0;
}
void connect(int u,int v){
    nEdge++;
    edge[nEdge].v=v;
    edge[nEdge].pre=p[u];
    p[u]=nEdge;
}
void dfs(int root,int kk){
    for(int i=p[root];~i;i=edge[i].pre){
        int son=edge[i].v;
        if(son==kk){
            continue;
        }
        dfs(son,root);
        for(int j=k;j>=1;j--){
         for(int t=1;t<=j;t++){
            dp[root][j][0]=max(dp[root][j][0],dp[root][j-t][1]+dp[son][t-1][0]);
            dp[root][j][0]=max(dp[root][j][0],dp[root][j-t][0]+dp[son][t-2][1]);
            dp[root][j][1]=max(dp[root][j][1],dp[root][j-t][1]+dp[son][t-2][1]);
         }
      }
    }
}
int main(){
    while(~scanf("%d%d",&n,&k)){
        Init();
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            for(int j=0;j<=k;j++){
                dp[i][j][0]=dp[i][j][1]=a[i];
            }
        }
        for(int i=1;i<n;i++){
            int u,v;
            scanf("%d%d",&u,&v);
            connect(u,v);
            connect(v,u);
        }
        dfs(1,0);
        printf("%d\n",max(dp[1][k][0],dp[1][k][1]));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值