Football----概率DP

Football
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5186 Accepted: 2644

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

题目链接:http://poj.org/problem?id=3071


第一次做概率DP


题目的大概题意是说:有2^n支队,现在要进行n次比赛,并且按次序进行比赛并淘汰,胜利的队继续按次序比赛并淘汰,比如1,2,3,4进行比赛,第一轮1和2比,3和4比,假如1和3胜利了,那么第二轮1和3继续比,2,4淘汰。最后问最有可能胜利的队伍是哪一支。


概率DP有个DP的通病,就是关键在于状态转移方程,概率DP的状态转移方程好难推。。。概率论大牛们的天堂。


分析题目,先创建状态,dp[i][j],表示在第i轮比赛中第j支队获胜,那么dp[0][j] = 1。然后考虑状态间的转移,很明显,如

果j队要在本轮中获胜,前提是在上一轮中必须要先获胜才有资格,即dp[i-1][j],并且在本轮中要击败所有可能的对手,那同时也

要求对手也要在上一轮中获胜,才有资格进入本轮,即p[j][k]*dp[i-1][k],其中p[j][k]代表j击败k的概率,所以状态转移方程为:

dp[i][j] = dp[i-1][j] * (dp[i-1][k]*p[j][k]),其中k为本轮与j比赛的队伍。可是,不知道大家发现没有,这里有一个问题,那

就是题目中说的淘汰制度,很明显必须要保证本轮比赛的双方曾经是没有比赛过的,因为如果两队曾经遇到过,必然会淘汰一队,那

么现在又怎么可能再次比赛呢?所以在进行状态转移之前必须加一个条件,保证j和k是第一次进行比赛,那当我们将比赛流程用二进

制表示时,会发现规律,当j>>(i-1) 等于 (k>>(i-1))^1时,j和k在第i轮比赛中第一次相遇。


这里的当j>>(i-1) 等于 (k>>(i-1))^1时,j和k在第i轮比赛中第一次相遇,这里可能有的人不太懂,其实这里是判断两支队伍

是否相邻的条件,举个例子:(2n)^(1)=2n+1;(2n+1)^(1)=2n,这样看就简单明了了吧,自己仔细想一下,我也是看大牛们这样写的,

又学了一招,异或运算符确实有好多妙用,注意优先级。

大牛们说这是概率DP的入门级题目,然而我半天也没想出来。。。


附上我学习概率DP时看到的大牛之一的链接:http://blog.csdn.net/u011787119/article/details/40151201


代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
using namespace std;
double dp[300][300];
double p[300][300];
int main(){
    int n;
    while(~scanf("%d",&n)&&n!=-1){
        memset(dp,0,sizeof(dp));
        for(int i=0;i<(int)pow(2,n);i++){
            dp[0][i]=1;
        }
        for(int i=0;i<(int)pow(2,n);i++){
            for(int j=0;j<(int)pow(2,n);j++){
                scanf("%lf",&p[i][j]);
            }
        }
        for(int i=1;i<=n;i++){
            for(int j=0;j<(int )pow(2,n);j++){
                for(int k=0;k<(int )pow(2,n);k++){
                    if((j>>(i-1))==((k>>(i-1))^1))
                        dp[i][j]+=dp[i-1][j]*(p[j][k]*dp[i-1][k]);
                }
            }
        }
        int ans=-1;
        double maxn=-1;
        for(int i=0;i<(int)pow(2,n);i++){
            if(dp[n][i]>maxn){
                maxn=dp[n][i];
                ans=i+1;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值