POJ 3071 - Football(概率DP 求概率)

39 篇文章 0 订阅

Football

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2898 Accepted: 1472

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all ij, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source



题意:

有2^n个球队,编号相邻的两个球队比赛,胜者晋级下一次比赛,然后又是相邻的队伍比赛,直到最后只剩一个球队,共n场比赛。问最大概率为冠军的队伍编号


思路:

dp[i][j] 表示第i次比赛中,j获胜的概率

则很容易想到 dp[i][j] = dp[i-1][j]*dp[i-1][k]*p[j][k],k为可以和j比赛的队伍

即上一场比赛j k都要胜出,然后这一次比赛j战胜k


位运算可以很方面的判断k在第i场比赛是不是和j相邻


#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <queue>
#include <set>

using namespace std;

//#define WIN
#ifdef WIN
typedef __int64 LL;
#define iform "%I64d"
#define oform "%I64d\n"
#define oform1 "%I64d"
#else
typedef long long LL;
#define iform "%lld"
#define oform "%lld\n"
#define oform1 "%lld"
#endif

#define S64I(a) scanf(iform, &(a))
#define P64I(a) printf(oform, (a))
#define P64I1(a) printf(oform1, (a))
#define REP(i, n) for(int (i)=0; (i)<n; (i)++)
#define REP1(i, n) for(int (i)=1; (i)<=(n); (i)++)
#define FOR(i, s, t) for(int (i)=(s); (i)<=(t); (i)++)

const int INF = 0x3f3f3f3f;
const double eps = 10e-9;
const double PI = (4.0*atan(1.0));

double p[200][200];
double dp[10][200];

int main() {
    int n;

    while(scanf("%d", &n) != EOF && n != -1) {
        int m = 1<<n;
        for(int i=0; i<m; i++) {
            for(int j=0; j<m; j++) {
                scanf("%lf", &p[i][j]);
            }
        }
        for(int i=0; i<m; i++) dp[0][i] = 1;
        for(int i=1; i<=n; i++) {
            for(int j=0; j<m; j++) {
                dp[i][j] = 0;
                for(int k=0; k<m; k++) if((j>>(i-1)^1) == k>>(i-1)) {
                    dp[i][j] += dp[i-1][j] * dp[i-1][k] * p[j][k];
                }
            }
        }
        double maxp = 0;
        int ans = -1;
        for(int i=0; i<m; i++) if(dp[n][i] > maxp) {
            maxp = dp[n][i];
            ans = i + 1;
        }
        printf("%d\n", ans);
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值