J - What day is that day? ----最小循环节

It's Saturday today, what day is it after 11 + 22 + 33 + ... + NN days?

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

There is only one line containing one integer N (1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input
2
1
2
Sample Output
Sunday
Thursday
Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday.


题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3785


这个题以前做过,问你1^1+2^2......+n^n天后星期几,这个题我不知道正解,打了个表,发现循环节是294,就水过了,过了。。。。。。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int a[1000];
char str[11][11]={"Saturday", "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday"};
void Init(){
    for(int i=1;i<=294;i++){
        int k=1;
        for(int j=1;j<=i;j++){
            k*=i;
            k%=7;
        }
        a[i]=(a[i-1]+k)%7;
    }
}
int main(){
    int t;
    Init();
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        n=(n-1)%294+1;
        int x=a[n]%7;
        printf("%s\n", str[x]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值