Seven Segment Display----数位dp

Seven Segment Display

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.

Edward, a student in Marjar University, is studying the course "Logic and Computer Design Fundamentals" this semester. He bought an eight-digit seven segment display component to make a hexadecimal counter for his course project.

In order to display a hexadecimal number, the seven segment display component needs to consume some electrical energy. The total energy cost for display a hexadecimal number on the component is the sum of the energy cost for displaying each digit of the number. Edward found the following table on the Internet, which describes the energy cost for display each kind of digit.

DigitEnergy Cost
(units/s)
06
12
25
35
44
55
66
73
DigitEnergy Cost
(units/s)
87
96
A6
B5
C4
D5
E5
F4

For example, in order to display the hexadecimal number "5A8BEF67" on the component for one second, 5 + 6 + 7 + 5 + 5 + 4 + 6 + 3 = 41 units of energy will be consumed.

Edward's hexadecimal counter works as follows:

  • The counter will only work for n seconds. After n seconds the counter will stop displaying.
  • At the beginning of the 1st second, the counter will begin to display a previously configured eight-digit hexadecimal number m.
  • At the end of the i-th second (1 ≤ i < n), the number displayed will be increased by 1. If the number displayed will be larger than the hexadecimal number "FFFFFFFF" after increasing, the counter will set the number to 0 and continue displaying.

Given n and m, Edward is interested in the total units of energy consumed by the seven segment display component. Can you help him by working out this problem?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 105), indicating the number of test cases. For each test case:

The first and only line contains an integer n (1 ≤ n ≤ 109) and a capitalized eight-digit hexadecimal number m (00000000 ≤ m ≤ FFFFFFFF), their meanings are described above.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case output one line, indicating the total units of energy consumed by the eight-digit seven segment display component.

Sample Input
3
5 89ABCDEF
3 FFFFFFFF
7 00000000
Sample Output
208
124
327
Hint

For the first test case, the counter will display 5 hexadecimal numbers (89ABCDEF, 89ABCDF0, 89ABCDF1, 89ABCDF2, 89ABCDF3) in 5 seconds. The total units of energy cost is (7 + 6 + 6 + 5 + 4 + 5 + 5 + 4) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 6) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 2) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) = 208.

For the second test case, the counter will display 3 hexadecimal numbers (FFFFFFFF, 00000000, 00000001) in 3 seconds. The total units of energy cost is (4 + 4 + 4 + 4 + 4 + 4 + 4 + 4) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 6) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 2) = 124.


Author:  ZHOU, Jiayu
Source:  The 14th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple
Submit     Status

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5594


题目的意思就是说给你一个n,给你一个十六进制的数,给你十六进制每个数的权值,让你计算经过n个数后,权值之和是多少。

比赛的时候队友想了三个小时没有想出来,赛后搜了大牛的题解,数位dp;

数位DP。n秒后如果没超过0xFFFFFFFF, 直接solve(r)-solve(l-1), 如果超过的话可以用一整段减去中间那段

不经过的,即solve(0xFFFFFFFF) - ( solve(r-1) - solve(l) ). ( r = (l+n-1)%(0xFFFFFFF)),

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#define LL long long
using namespace std;
const LL mod=(LL)0xffffffff+1;
int val[16]={6,2,5,5,4,5,6,3,7,6,6,5,4,5,5,4};
int a[20];
LL dp[20][1005];
LL change(char *str){
    LL tmp=0;
    for(int i=0;i<8;i++){
        if(str[i]>='0'&&str[i]<='9'){
            tmp=tmp*16+str[i]-'0';
        }
        else{
            tmp=tmp*16+str[i]-'A'+10;
        }
    }
    return tmp;
}
LL dfs(int pos,LL sum,int limit){
    if(pos<0)
        return sum;
    if(!limit&&dp[pos][sum]!=-1)
        return dp[pos][sum];
    int up=limit?a[pos]:15;
    LL tmp=0;
    for(int i=0;i<=up;i++){
        tmp+=dfs(pos-1,sum+val[i],limit&&(i==a[pos]));
    }
    if(!limit)
        dp[pos][sum]=tmp;
    return tmp;
}
LL solve(LL x){
    int pos=0;
    memset(a,0,sizeof(a));
    while(x){
        a[pos++]=x%16;
        x/=16;
    }
    return dfs(7,0,1);
}
int main(){
    LL setp;
    int t;
    char str[20];
    memset(dp,-1,sizeof(dp));
    scanf("%d",&t);
    while(t--){
        scanf("%lld %s",&setp,str);
        setp--;
        LL l=change(str);
        LL bei=setp/mod;
        if(l+setp>=mod){
            LL r=(l+setp)%mod;
            printf("%lld\n",(bei+1)*solve((LL)0xffffffff)-(solve(l-1)-solve(r)));
        }
        else{
            LL r=l+setp;
            printf("%lld\n",bei*solve((LL)0xffffffff)+solve(r)-solve(l-1));
        }
    }
    return 0;
}

大牛链接: http://blog.csdn.net/cillyb/article/details/70474057


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值